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はじめに 

 

 

走査プローブ顕微鏡（SPM）は、無機結晶表面から半導体微細構造、有機分子、自己組

織化膜、タンパク質分子、DNA などの生体ナノ構造に至るまで、自然界あるいは人工的な

超微細構造と微細スケールにおける物性を計測し、それらの機能開発を導く強力な実験法

です。ところが、SPM の探針先端と試料間のナノ領域では、原子レベルの力学的・電子的・

化学的過程が複雑に絡み合っているため、実験結果の解析に理論的な支援がなければ難し

いのが現状です。 

本シミュレータは、このような必要性に応えるために開発いたしました。従来の研究レ

ベルの SPM シミュレーション技術をベースとした上で、問題に応じた計算規模の軽減が行

えるように複数のソフトウェアを用意し選択できるようにいたしました。また、容易な操

作を支援する GUI（グラフィカルユーザーインターフェース）を備えたものに仕上げてい

ます。 

今後 SPM 計測技術は、物理化学、生命科学、電子情報工学、材料科学などの先端的基礎

研究分野のみならず、半導体デバイス、表面処理技術、高分子材料、バイオ科学、農学、

先端医療、環境触媒、燃料電池、洗剤・化粧品業界などの産業分野においても重要性を増

すものと考えられます。このような分野での研究ツールとして本シミュレータがお役に立

てば幸いです。 
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 本書は弊社 SPM シミュレータの操作手順書となっており、ソフトウェアのインストール

から操作手順、注意事項などをご紹介いたします。本書では初心者の方にも簡単にお使い

いただけるよう、基本的な操作方法を中心に解説しております。詳細設定に関しましては

別紙リファレンスマニュアルをご覧ください。 
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SPMシミュレータの構成 

 

 

弊社 SPM シミュレータには、以下のように大きく５つの機能があります。 

 

       １．高速相互予測 AFM シミュレータ 

       ２．連続弾性体 AFM シミュレータ 

       ３．液中ソフトマテリアル AFM シミュレータ 

       ４．原子分子ナノ材料 AFM 像シミュレータ 

       ５．量子論的 SPM 像シミュレータ 

 

そして、補助機能として、試料構造モデリング機能を備えています。 

上記５つの機能は、以下の６つのシミュレータから構成されています。 

 

① GEO  ② FEM  ③ LIQ  ④ CG  ⑤ MD  ⑥ DFTB 

 

それぞれのシミュレータの分類、機能概要、および対象領域は以下の表のようになってい

ます。 

 

表１：各シミュレータの機能概要 
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古典力学に基づき、探針－試料間でのファンデルワールス力を考慮し、その上で、探針
及び試料が弾性方程式に従うと仮定して、測定AFM像を予測するシミュレータ
（探針形状データおよび試料表面形状データを入力として、測定AFM像データを予測・
出力する）

FEM連続弾性体AFMシミュレータ

探針形状データ、試料表面形状データ、測定AFM像データ、の三種類のデータのうち、
二種類のデータから、残り一種類のデータを高速に予測するシミュレータ

（シミュレーション計算においては、探針－試料間の相互作用を考慮せず、また、探
針・試料の立体形状は変形しないと仮定して、純粋に幾何学的な計算により、データを
相互予測する）

高速相互予測AFMシミュレータ GEO

DFTB

MD

CG

LIQ

ｼﾐｭﾚｰﾀ
名称

接触電位差を計算し、KPFM像を予測する機能

トンネル電流計算を行い、STM像を予測する機能

化学的相互作用力を計算し、AFM像を予測する機能

量子力学に基づいて系の電子状態を求め、探針－試料間の相互作用を計算。その結果か
らAFM像/STM像/KPFM像を予測するシミュレータ。

分子動力学法に基づいて試料の変形を考慮し、AFM像を予測するシミュレータ

エネルギー緩和法に基づいて試料の変形を考慮し、AFM像を予測するシミュレータ

古典力学に基づき、力場ポテンシャルを用いることにより探針－試料間の相互作用を計
算し、AFM像を予測するシミュレータ

液中でのカンチレバーの運動を，流体及び試料から受ける抗力とレバー自身の弾性変形
を考慮して計算するシミュレータ

概要

構造最適化AFM像シミュレータ

分子動力学AFM像シミュレータ

AFM像シミュレーション

STM像シミュレーション

KPFM像シミュレーション

量子論的SPM像シミュレータ

原子分子ナノ材料AFM像シミュレータ

液中ソフトマテリアルAFMシミュレータ

古典力学に基づき、探針－試料間でのファンデルワールス力を考慮し、その上で、探針
及び試料が弾性方程式に従うと仮定して、測定AFM像を予測するシミュレータ
（探針形状データおよび試料表面形状データを入力として、測定AFM像データを予測・
出力する）

FEM連続弾性体AFMシミュレータ

探針形状データ、試料表面形状データ、測定AFM像データ、の三種類のデータのうち、
二種類のデータから、残り一種類のデータを高速に予測するシミュレータ

（シミュレーション計算においては、探針－試料間の相互作用を考慮せず、また、探
針・試料の立体形状は変形しないと仮定して、純粋に幾何学的な計算により、データを
相互予測する）

高速相互予測AFMシミュレータ GEO

DFTB

MD

CG

LIQ

ｼﾐｭﾚｰﾀ
名称

接触電位差を計算し、KPFM像を予測する機能

トンネル電流計算を行い、STM像を予測する機能

化学的相互作用力を計算し、AFM像を予測する機能

量子力学に基づいて系の電子状態を求め、探針－試料間の相互作用を計算。その結果か
らAFM像/STM像/KPFM像を予測するシミュレータ。

分子動力学法に基づいて試料の変形を考慮し、AFM像を予測するシミュレータ

エネルギー緩和法に基づいて試料の変形を考慮し、AFM像を予測するシミュレータ

古典力学に基づき、力場ポテンシャルを用いることにより探針－試料間の相互作用を計
算し、AFM像を予測するシミュレータ

液中でのカンチレバーの運動を，流体及び試料から受ける抗力とレバー自身の弾性変形
を考慮して計算するシミュレータ

概要

構造最適化AFM像シミュレータ

分子動力学AFM像シミュレータ

AFM像シミュレーション

STM像シミュレーション

KPFM像シミュレーション

量子論的SPM像シミュレータ

原子分子ナノ材料AFM像シミュレータ

液中ソフトマテリアルAFMシミュレータ

 

 

表２：補助機能の機能概要 

外部フリーソフトウェア
で対応

外部フリーソフトウェア
で対応

無償版に添付して配布

開発中

備考

プロテインデータバンクの利用

分子構造の作成と編集

結晶構造のデータからの半導体薄膜モデルの作成と編集

初期構造の作成

測定像とシミュレーション像を比較し、類似物から試料の
構造を予測する機能

概要

半導体薄膜構造作成ツール

分子構造作成

たんぱく質

モデリング機能

試料表面構造予測機能

外部フリーソフトウェア
で対応

外部フリーソフトウェア
で対応

無償版に添付して配布

開発中

備考

プロテインデータバンクの利用

分子構造の作成と編集

結晶構造のデータからの半導体薄膜モデルの作成と編集

初期構造の作成

測定像とシミュレーション像を比較し、類似物から試料の
構造を予測する機能

概要

半導体薄膜構造作成ツール

分子構造作成

たんぱく質

モデリング機能

試料表面構造予測機能

 

 

 

表３：各シミュレータの対象領域 

 10



試料、探針の変形を考慮可能－○－○FEM連続弾性体AFMシミュレータ

1秒以内で計算可能ナノスケール半
導体デバイス、
（生体）高分子
化合物

－○－○高速相互予測AFMシミュレータ GEO

DFTB

MD

CG

LIQ

ｼﾐｭﾚｰﾀ
名称

－○

－○

－○

●○

●○

液中
真空
中

○

環境

○

有機低分子、無
機物質等

高分子化合物、
生体分子等

対象

試料

試料の変形を考慮可能

温度を考慮可能

試料の変形を考慮可能

その他特徴

○－
構造最適化AFM像シミュ
レータ

原子分子
ナノ材料
AFM像シ
ミュレータ ○－

分子動力学AFM像シミュ
レータ

○－AFM像シミュレーション
量子論的
SPM像シ
ミュレータ

○－STM像シミュレーション

○●KPFM像シミュレーション

対象スケール

－○液中ソフトマテリアルAFMシミュレータ

ミクロマクロ

試料、探針の変形を考慮可能－○－○FEM連続弾性体AFMシミュレータ

1秒以内で計算可能ナノスケール半
導体デバイス、
（生体）高分子
化合物

－○－○高速相互予測AFMシミュレータ GEO

DFTB

MD

CG

LIQ

ｼﾐｭﾚｰﾀ
名称

－○

－○

－○

●○

●○

液中
真空
中

○

環境

○

有機低分子、無
機物質等

高分子化合物、
生体分子等

対象

試料

試料の変形を考慮可能

温度を考慮可能

試料の変形を考慮可能

その他特徴

○－
構造最適化AFM像シミュ
レータ

原子分子
ナノ材料
AFM像シ
ミュレータ ○－

分子動力学AFM像シミュ
レータ

○－AFM像シミュレーション
量子論的
SPM像シ
ミュレータ

○－STM像シミュレーション

○●KPFM像シミュレーション

対象スケール

－○液中ソフトマテリアルAFMシミュレータ

ミクロマクロ

 

○：無償版、製品版ともに対応 

●：製品版のみ対応      

－：未対応          

 

 高速相互予測 AFM シミュレータ                        

高速相互予測 AFM シミュレータでは、「探

針形状データ」、「試料表面形状データ」、「測

定 AFM 像データ」の三種類のデータのうち、

二種類のデータから、残り一つのデータを高

速数値計算によって求めます。このシミュレ

ータは、探針が試料に常に接しているコンタクトモード測定を仮定しており、純粋に幾何

学的な計算手法によって解を求める点に特徴が有ります。 

 連続弾性体 AFM シミュレータ                            

連続弾性体 AFM シミュレータでは、探針－試
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料間のファンデルワールス力を考慮し、その上で、探針および試料が(古典的な)弾性方程式

に従うと仮定して有限要素法計算を実行し、予測される AFM 画像を求めます。このシミュ

レータでは、カンチレバーの先端の探針は、常に試料表面から数Å程度離れており、ノンコ

ンタクトモード測定に対応します。 

 

 

 液中ソフトマテリアル AFM シミュレータ                    

液中ソフトマテリアル AFM シミュレータでは、液中の動的 AFM に対応し、カンチレバ

ーの振動解析、粘弾性ソフトマテリアルの SPM 計

測をシミュレーションすることができます。液中で

のカンチレバーの運動の様子を、周辺流体から受け

る抗力、試料との接触によって受ける力、レバー自

身の弾性変形の 3 つを練成して計算します。 本シミュレータでは、振動モードでの粘弾性

試料の AFM 像を計算することができ（開発中）、試料の弾性率などの物性値を推測するこ

とが可能です。また、液中でのカンチレバーの共鳴振動周波数を特定することができ振動

特性が分かるので、カンチレバー形状の設計、振動条件の検討に役立ちます。 

 

 

 原子分子ナノ材料 AFM 像シミュレータ                     

 原子分子ナノ材料 AFM 像シミュレータは、
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対象とする AFM 測定試料の原子一つ一つに力場パラメータを設定し、それらに基づいて、

走査される探針と試料との間の相互作用を計算することにより、AFM 測定像を予測するシ

ミュレータです。また、探針との相互作用による試料分子の構造変化を原子スケールで予

測することができることに特徴があります。このシミュレータには分子構造を計算する手

法として二種類用意されています。一つは、分子がエネルギー的に安定になる原子配置を

探索し、分子構造を決定する「構造最適化 AFM 像シミュレータ」です。もう一つは、すべ

ての原子についてのニュートン方程式を解くことにより分子構造の変化過程を予測する

「分子動力学 AFM 像シミュレータ」です。これらのうちから目的に応じて選び、シミュレ

ーションを行うことができます。 

 

 

 量子論的 SPM 像シミュレータ                         

量子論的 SPM 像シミュレータでは、量子力学的

な電子状態の計算を元に、真空中のミクロスケール

な表面構造に対する周波数シフト像、トンネル電流

像、および局所接触電位差像のシミュレーションを

行うことができます。また、トンネル電流の計算では、走査トンネル分光スペクトルとし

ても解析することができます。本シミュレータでは、密度汎関数理論に基づく強束縛計算

法を採用しており、量子力学計算に通常付随する大きな計算コストを軽減させています。
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そのため、実験との比較を行う上で現実的な試料表面や、古典分子動力学法によって評価

した比較的大きな系に対して適応することが可能です。 

 

 

 モデリング機能                                

 半導体表面作成ツールは、補助機能のひとつで、

SPM シミュレータの初期構造を作成するためのツ

ールです。このツールでは、ミクロスケール（DFTB

法、CG 法、MD 法）で使用される原子モデルを作成

しますが、一部マクロスケールでも使用することができます。ミクロスケールで使用され

る原子モデルとして、理想表面を持つ薄膜モデルが作成されます。また、任意の原子・ク

ラスタの追加・削除・移動の編集を行う事ができます。 

 

 

 

 

 14



 



 

ご希望シミ レ タ 選択（複数可） 
                   ・           ・           ・           ・ 
 

 

 

 

 

 

 

 

 

 

 

 

申し込みの後、e-mail にてアカウント ID 及びライセンスキーと入手先のURL が提供されます。 

 

 

インストールプログラムをダウンロードし、PC へ保存します。 

ファイル名は SPMInstaller.zip となります。 
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上記を入力 上 送信



 

 

 

 

 

 

 

SPMInstaller.zip を解凍します。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

解凍すると SPMInstaller というフォルダが作成されます。SPMInstaller フォルダを開きます。 
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Installer.exe をダブルクリックして実行します。 

以下の画面が表示されます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

続いて以下の画面が表示されますので、Next ボタンをクリックします。 
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本ソフトウェアの使用条件が表示されますので、ご一読頂き、ご同意の上でインストール

を続けて頂きます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

「同意する」のラジオボタンをチェックすると Next ボタンをクリックできる状態になりま

す。続けて Next ボタンをクリックします。 
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アカウント ID とラインセンスキーの入力画面に変わります。 

e-mail にて送付されたアカウント ID とライセンスキーを入力し、OK ボタンをクリックし

ます。 
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以下、画面が表示されます。 

インストール先のフォルダを選択し、OK ボタンをクリックします。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

SPM Simulator モジュールのインストールが開始されます。 
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SPM Simulator モジュールのインストールが終了すると Next ボタンをクリックできる状態

になります。Next ボタンをクリックします。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

サーバへの登録画面が表示されます。 
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サーバへの登録が完了すると以下が表示され、Next ボタンをクリックできる状態になりま

す。Next ボタンをクリックします。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

終了の画面が表示されます。デスクトップショートカットならびにスタートメニューへの

登録ができます。チェックボックスの必要箇所にチェックし Finish ボタンをクリックしま

す。インストールは以上で終了です。 
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２ パラメータファイルの準備（原子分子ナノ材料 AFM 像シミュレータのみ） ２ パラメータファイルの準備（原子分子ナノ材料 AFM 像シミュレータのみ）

 
 

原子分子ナノ材料 AFM 像シミュレータでは、探針と試料の間や分子内部の相互作用を計算

する際に MM3 という力場パラメータを用います。そのために、このシミュレータでシミュ

レーションを行うためには、MM3 のパラメータファイルを入手して、シミュレータの指定

場所に置く必要があります。手順は以下の通りです。 

 

１．TINKERホームページ(URL: http://dasher.wustl.edu/tinker/)を表示します。 

２．“TINKER Downloads”の項目内の“Force Field Parameter Sets”の右”DIRECTORY”をク

リックする。 

３．“mm3.prm”をダウンロードする。 

４．“mm3.prm”ファイルを SPM シミュレータのフォルダ内、”CG/parameter”と”MD/prm”

の場所にそれぞれコピーする。 

 

以上で準備完了です。 
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第２章 

ソフトウェアの操作 
 

 

 

1 GUI 概要 １ GUI 概要                    
 

本ソフトウェアでは、探針、試料、画像などのコンポーネントデータやそれらの初期配置、

各シミュレータで用いられるパラメータ、計算結果出力ファイルパスなど、シミュレーシ

ョンに必要な全ての情報を『プロジェクト』と呼ばれる XML 形式のファイルで一括管理し

ています。各シミュレータは、このプロジェクトファイルを入力とし、計算途中あるいは

終了後、結果を指定されたパスに出力します。統合 GUI を用いることで、プロジェクトフ

ァイルの作成・編集を簡単に行うことができ、また結果ファイルを様々な形態で可視化・

表示することができます（図）。 
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プロジェクトファイル

作成、編集 

表示 

計算結果ファイル 

統合GUI 

参照 

シミュレータ

GEO 

FEM 

LIQ 

CG 

MD 

DFTB 

コンポーネントデータ 

(探針、試料、画像) 
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2 画面説明 ２ 画面説明 
 

Menu Bar & Tool Bar 

Main View 
Result View 

Project Editor 
Log View 

Project View 

DB View 
Data View 
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以下では画面ごとの主な機能について説明します。 

【Menu Bar & Tool Bar】 

プロジェクトの新規作成や読み込み、保存などのファイル操作、シミュレータの選択

や実行、再生、一時停止、停止などのシミュレーション制御操作、各画面の表示／非

表示の切り替えなどを行います。 

 

【Project Editor】 

プロジェクトファイルの内容をツリービューとして表示します。表示された値は直接

編集することができます。変更内容は即座に Main View 上の描画に反映されます。 

 

【Main View】 

プロジェクトファイルに書かれているコンポーネントやそれらの初期配置、スキャン

エリアなどのセットアップ情報を可視化します。マウスやキーボード、スライダーバ

ーの操作によってコンポーネントのレイアウトを変更でき、その内容は即座に Project 

Editor に反映されます。またシミュレーション実行中には、探針の移動や試料の変形の

様子を可視化します。 

 

【Result View】 

シミュレーション途中や終了後の計算結果を可視化し、２D、３D など様々な形態で表

示します。 
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【Log View】 

シミュレータや GUI からのメッセージを表示します。 

 

【DB View】 

予めデータベースに登録されたコンポーネント（探針や試料の分子データ）の一覧表

を表示します。一覧表の中からコンポーネントを選択・ダブルクリックするだけでプ

ロジェクトに取り込むことができます。 

 

【Project View】 

プロジェクトファイルの内容をテキスト表示します。直接編集することはできません。 

 

【Data View】 

コンポーネントのデータを表示します。分子データの場合、原子ごとに電荷情報と移

動可／不可の情報を設定・編集することができます。ただし原子種と原子座標は編集

できません。 

3 GUI の起動 ３ GUI の起動 
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1. a. デスクトップ  “SPM Simulators”アイコン ダブルクリック 

1. b. インストールディレクトリ¥SPMSimulator.exe ダブルクリック 

 

正常に起動しない場合、ig4dev32.dll（通常は C:¥WINDOWS¥system32 にあります）のバ

ー ジ ョ ン が 合 っ て い な い 可 能 性 が あ り ま す 。 こ の フ ァ イ ル 名 を 別 名 （ 例 え ば 、

ig4dev32.dll_bak）に変更後、再度 GUI を起動してみてください。 

なお、他のアプリケーションで不都合が出た場合は、お手数ですが元にお戻しください 
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4 プロジェクトのファイル操作 

  

GUI を起動後、全ての操作はプロジェクトを読み込むことから始まります。プロジェク

ト読み込み後、GUI を用いてそのプロジェクトを編集・保存し、最後にシミュレーション

を実行するという手順になります。ここでは、プロジェクトの新規作成や読み込み、保存

などのファイル操作について説明します。 

 

█ 新規プロジェクト作成                         

 

Simulator Tab 

４ プロジェクトのファイル操作 

 

1. “Menu Bar” → [File] → [New]1 → ”Create new project”ダイアログ 

2. “Project name”入力 → “Directory”入力 → [OK] 

                                                  
1 この操作は、”Tool Bar” → Newアイコンをクリックすることでも行えます。 
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”Create new project”ダイアログでは、プロジェクト名(Project name)およびプロジェクト作

成ディレクトリ(Directory)を指定します。[Ref]ボタンを押すとダイアログを用いてディレク

トリを指定できます。[OK]ボタンを押すと “Directory”で指定されたディレクトリの中に、

プロジェクトと同名のディレクトリが作成され、その中にプロジェクトファイルが作成さ

れます。例えば test というプロジェクト名を指定した場合、 

指定したディレクトリ¥test¥test.pro 

 

というプロジェクトが作成されます。プロジェクトが作成されると、”Project Editor”

の”Setup”タブ内には”Component”項目が追加され、”Simulator Tab”（図では”DFTB”）内に

はデフォルトのパラメータ値が自動設定されます。 

 

█ 既存プロジェクト読み込み                       

【ファイルダイアログを使用した読み込み】 
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1. “Menu Bar” → [File] → [Open]2 → ”Open Project”ダイアログ 

2. プロジェクトファイル(～.pro)指定 → [開く] 

 

指定されたプロジェクトが読み込まれると、”Project Editor”の各タブ内にセットアップ情報

                                                  
2 この操作は、”Tool Bar” → Openアイコンをクリックすることでも行えます。 
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やシミュレータのパラメータ情報などが表示されます。同時に Main View 上に探針や試料

などのコンポーネントが描画されます。また既に計算結果がある場合は、”Result View”に結

果情報がセットされます。 

 

【最近使用したプロジェクトの読み込み】 

 

1. “Menu Bar” → [File] → [Recent Files] → プロジェクト一覧3→ファイル指定 

 

【再読み込み】 

 

 

                                                  
3 最近使ったプロジェクトファイルは最大 10 個まで表示されます。 
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1. “Menu Bar” → [File] → [Reload]4

セットアップ情報やパラメータ値を変更した時、保存前であれば、再読み込みすることで

前回保存した時点のプロジェクトに戻すことができます。 

 

 

█ プロジェクトの表示                          

 

1. “Menu Bar” → [Display] → [Current Project File:ファイル名] 

 

Current Project File:の後には、現在のプロジェクトファイル名が表示されます。このメニュ

                                                  
4 この操作は、”Tool Bar” → Reloadアイコンクリックでも行えます。 
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ーをクリックすることで、”Project View”が立ち上がり、プロジェクトファイルの内容を閲

覧することができます。なお、”Project View”上でファイルを直接編集することはできませ

ん。編集は”Project Editor”から行います。 

 

█ プロジェクトの保存                          

 

GUI 上でプロジェクトを編集した場合、その内容が直ちにプロジェクトファイルに反映さ

れるわけではありません。保存をしてはじめてプロジェクトファイルが更新されます。各

シミュレータはプロジェクトファイルを参照して計算を行うため、プロジェクトの変更内

容をシミュレーション結果に反映させるためには、実行前にファイルを保存しておく必要

があります。以下では保存方法について説明します。 

 

【保存】 

1. “Manu Bar” → [File] → [Save]5  

 

                                                  
5 この操作は”Tool Bar”のSaveアイコンをクリックすることでも行えます。 
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【名前を付けて保存】 

 

 

1.“Manu Bar”→ [File] → [Save As] → “Save Project ”ダイアログ 

2. “Project name”入力 → “Directory”入力 → [OK] 

ダイアログでは、プロジェクト名(Project name)およびプロジェクトファイ

ル作成ディレクトリ(Directory)を指定します。[Ref]ボタンを押すとダイアログを用いてディ

レクトリを指定できます。[OK]ボタンを押すと “Directory”で指定されたディレクトリの中

に、プロジェクトと同名のディレクトリ（プロジェクトディレクトリ）を作成し、その中

にプロジェクトファイルを作成・保存します。その際、データファイルなどプロジェクト

に必要な全てのファイルがプロジェクトディレクトリにコピーされます。 

上部のタイトルバーに現在のプロジェクトファイル名が表示されていますが、編集し

てファイルを書き換えた場合には、このファイル名の後に”*”という記号が表示されます。

 

” Save Project”

 

GUI
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保存が完了するとこの記号が消えます。 

 

 

█ プロジェクトの終了                          

 

 

 

1.“Manu Bar”→ [File] → [Close]6  

 

プロジェクトを終了すると、”Project Editor”から全項目が削除されます。また”Main View”

上の描画も全て消去されます。 

 

 

 

                                                  
6 この操作は”Tool Bar”のCloseアイコンをクリックすることでも行えます。 
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5 プロジェクトの編集 ５ プロジェクトの編集 
 

█ コンポーネント                            

 

（１） 追加・置換・削除 

コンポーネントは、探針・試料・画像の３種類ありますが、以下では探針の場合を例にと

って説明します。 

 

【追加】 
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1. “Project Editor” → “Setup”タブ 

2. “Component”右クリック → コンテクストメニュー7

3. a. [Add Tip] → [Database] → “DB View” → コンポーネントダブルクリック 

b. [Add Tip] → [File] → “Import File”ダイアログ → ファイル指定 → [開く] 

c. [Add Tip] → [Sphere/Cone/Pyramid/Pillar] → パラメータ入力ダイアログ → 半径・角
                                                  
7
このメニューは、”Menu Bar” → [Edit] を選択すること、あるいは”Main View”上で右クリックすることでも表示

できます。 
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度入力 → [OK] 

 

 

探針の場合、追加データは[Database]（データベース）、[File]（ファイル）および 4 種類の

形状モデル[Sphere][Cone][Pyramid][Pillar]から選択可能ですが、各々入力ダイアログが異な

ります8。データベースからの入力の場合、一覧からコンポーネントを選択し、ダブルクリ

ックするだけで追加できます。ファイルからの入力の場合は、ファイルダイアログを使い

ます。形状モデルの場合は、形状に応じて角度や半径などの入力ダイアログが立ち上がり

ます。 

 

以上の操作で、指定されたデータが読み込まれると、”Component”の下に”Tip”という項目が

追加され、探針の情報が表示されます。同時にMain View上に探針が描画されます。試料、

画像についても同様の手順で追加していくことができます9。 

 

【画像ファイルの追加】 

bmpやjpgなどの画像ファイルは、明るさの情報はもちますが、高さ情報はもっていません。

したがって、明度をコンポーネントの高さ情報に変換する処理が必要となります10。また、

画像の大きさ（幅、高さ）が現実に何Åに相当するかを指定する必要があります。以下では

試料の場合を例にとって画像ファイルの読み込みについて説明します。 
                                                  
8
試料は[Database]および[File]から、画像は[File]からのみ入力可能です。  
9
試料は複数個追加することができますが、探針および画像はひとつだけしか追加できません。 
10
 画像の明度と試料の高さが比例関係にない場合には、画像ファイルを追加しても正しい計算は行えません。 
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1. “Project Editor” → “Setup”タブ 

2. “Component”右クリック → コンテクストメニュー11

3. [Add Sample] → [File] → “Import File”ダイアログ → 画像ファイル指定 → [開く] 

4.”Set Image Width”ダイアログ → “width”入力 → [OK] 

5.”Set Image Height”ダイアログ → “height”入力 → [OK] 

6.”Set Value Range”ダイアログ → “value range”入力 → [OK] 

 

“Set Image Width”および“Set Image Height”ダイアログで、画像ファイルの幅と高さが実際

に何Åに相当するのかを指定します。さらに“Set Value Range”ダイアログで、画像の明度

                                                  
11
このメニューは、”Menu Bar” → [Edit] を選択すること、あるいは”Main View”上で右クリックすることでも表

示できます。 
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[0.0,1.0](黒=0.0、白=1.0 で表現)がどれくらいの試料の高低差（Å）に相当するのかを指定

します。 

 

 

 

 

 

 

【置換】 

 

1. “Project Editor” → “Setup”タブ 

2. “Tip”右クリック → コンテクストメニュー 

3. a. [Replace] → [Database] → “DB View” → コンポーネントダブルクリック 

b. [Replace] → [File] → “Import File”ダイアログ → ファイル指定 → [開く] 

c. [Replace] → 形状モデル → パラメータ入力ダイアログ → 半径・角度入力 → [OK] 

 

置換と追加の違いは、2.の操作において”Component”ではなく、置換したいコンポーネント
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（探針の場合は”Tip”）を右クリックすることと、3.の操作においてコンテクストメニューの

内容が、[Add Tip]ではなく[Replace]に変わることです。 

 

【削除】 

 

1. “Project Editor” → “Setup”タブ 

2. “Tip”右クリック → コンテクストメニュー 

3. [Remove] 

 

指定されたデータが削除されると、”Component”の下から”Tip”という項目が削除されます。

同時に Main View 上からも探針の可視化画像が削除されます。 

 

 

（２） 初期配置設定（移動・回転・リセット） 

コンポーネントは、探針・試料・画像の３種類ありますが、以下では探針の場合を例にと

って説明します。 
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【移動】 

 

ここでは、z 座標の移動を例にとって説明します。 

1. “Project Editor” → “Setup”タブ 

2. a. “Tip” → “Position”12 → “z”の”value”ダブルクリック → スピンボックス 

  b. “Tip” → “DistanceFromSamples”13の”value”ダブルクリック → スピンボックス14

3. 数値入力15 → リターン 

以上の操作で、Main View 上に表示されている探針が、指定された座標に移動します。 

                                                  
12 ”Position”以下には、コンポーネントの座標（単位はÅ）が格納されています。探針に関して、”x”、”y”、 ”z”
の”value”値は、探針最下端位置の座標を表します。一方、試料と画像に関しては、”x”と”y”の”value”値は、

各々コンポーネント中心のx座標(xmin+xmax)/2 , y座標(ymin+ymax)/2 を表します。”z”の”value”値はコンポーネ

ント最下端のz座標（zmin）を表します。 
13
 ”DistanceFromSamples”の”value”値（単位はÅ）は、（探針最下端のz座標－試料最上端のz座標）を表します。

試料が存在しない場合、この値は 0となります。 
14 この操作はz座標移動の場合のみ有効となります。 
15 数値変更は、”Main View”内のスライダーバーつまみを移動させること、あるいは”Main View”上で”Shift”キ
ーを押しながらマウスを移動させることによっても行えます。ただし”Main View”上のマウス操作でコンポーネントを

移動・回転（後述）させる場合、”Project Editor”の”Setup”タブ内で、そのコンポーネントを選択（９節）してお

く必要があります。何も選択されていない場合は、視点が変更されます。 
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【回転】 

 

ここでは、x方向軸に関する回転を例にとって説明します16。 

1. “Project Editor” → “Setup”タブ 

2. “Tip” → “Rotation”17 → “alpha”の”value”ダブルクリック → スピンボックス 

3. 数値入力18 → リターン 

 

以上の操作で、Main View 上に表示されている探針が、x 方向の軸を中心に、指定された角

度だけ回転します。y および z 方向軸の回転に関しても同様です。なお、画像に関しては回
                                                  
16 現在回転操作を行えるのは、”～.pdb”、”～.xyz”、”～.txyz”形式のデータをもつコンポーネント
のみとなっています。 
17 ”Rotation”以下には、軸に対する回転角度（単位はdegree）が格納されています。”alpha”、”beta”、”gamma”
の”value”値は、各々回転中心を原点とした場合のx、y、z方向の軸に対する回転角度を表します。回転中心は、探針

の場合、探針最下端位置となります。一方試料の場合、コンポーネントの中心座標が回転中心となります。回転は“alpha”

→“beta”→“gamma”の順序で行います。 
18 入力できる数値の範囲は[-180degree , 180degree]となっています。数値変更は、”Main View”上でマウスを移動
させることによっても行えます。 

 47



転操作を行うことができません。 

 

 

【リセット】 

Reset Layout 

 

1.“Tool Bar” → [Reset Layout] 

 

以上の操作で各コンポーネントの位置座標および回転角度は、その時点で保存されている

プロジェクトファイルの値にリセットされます。同時に、Main View 上に描画されているコ

ンポーネントの配置もリセットされます。 

 

 

（３） データ表示・属性変更 

以下では試料のデータを表示する場合について説明します。 
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1.“Project Editor” → “Setup”タブ 

2.“Sample”右クリック → コンテクストメニュー → [Show] → “Data View” 

3.“Relax”19および”Charge”列の数値入力20→ [OK] 

 

以上の操作で、各原子の属性が書き換えられ、変更内容はプロジェクトファイルに保存さ

れます。”Relax”の値を 1 にした場合、シミュレーション途中で働く力に応じて原子が動く

ことがあります。この場合、原子の配置が変更されることにより分子（コンポーネント）

が変形します。 

█ スキャンエリア設定・表示                       

 

ここでは、スキャンエリアの高さ（z 軸方向の走査範囲）の変更を例にとって説明します。 

                                                  
19
 “Relax”=0 は原子座標の「移動不可」、“Relax”=1 は「移動可」を表します。 
20
 現在属性変更を行えるのは、”～.pdb”、”～.xyz”、”～.txyz”形式のデータをもつコンポーネントのみとなっ

ています。なお、原子種および原子座標は編集することができません。 
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1.“Project Editor” → “Setup”タブ 

2.“Tip” → “ScanArea”21 → “h”の”value”ダブルクリック → スピンボックス 

3.数値入力→ リターン 

4.“Main View”右クリック → コンテクストメニュー → [Show Scan Area]22

 

以上の操作で、プロジェクトの走査範囲が変更され、その範囲が”Main View”上に青色の直

方体で表示されます。 

 

 

                                                  
21 ”ScanArea”以下には、走査範囲の幅w、奥行きd、高さh（単位はÅ）が格納されています。w、d、h各々の値は、探
針の最下端を始点とし、x方向、y方向、-z方向へどれだけ走査するかを表します。 
22 [Show Scan Area]はトグルボタンであり、繰り返しクリックすることで走査範囲の表示／非表示を交互に切り替えら
れます。 
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█ シミュレータ選択とパラメータ設定                   

 

以下では量子論的 SPM 像シミュレータ(DFTB)を選択する場合について説明します。 

Simulator Combo Box

Simulator Tab

 

1.“Tool Bar” → “Simulator Combo Box” → [MD/CG/DFTB/FEM/LIQ]23

2.“Project Editor” → “Simulator Tab” 

3.各パラメータの”value”ダブルクリック → 各種入力コントロール24

4.データ入力→ リターン 

 

パラメータ設定を行うためには、まず設定したいシミュレータを選択する必要がありま

                                                  
23 シミュレータ選択は、”Menu Bar” → [Simulation] → [Solver]からでも行えます。 
24 入力コントロールは、数値の場合はスピンボックス、文字の場合はテキストボックスといったように、要求されるデ
ータ形式に応じて自動的に変化します。 
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す。”Simulator Combo Box”からMD/CG/DFTB/FEM/LIQの内、いずれかを選択します25。選

択されたシミュレータに応じて“Simulator Tab”の文字は自動的に変更されます（図では

DFTB）。次に“Simulator Tab”内で各パラメータ値を入力します。各パラメータの意味につい

ては、別紙「リファレンスマニュアル」を参照してください。なお新規プロジェクトを作

成した場合でも、各パラメータには予めデフォルト値が設定されています。 

 

どのシミュレータを選択しても、”Simulator Tab”内に”Output”という項目が存在し、その直

下に”Directory”という項目があります。”Directory”以下は計算結果ファイル名のリストです。

シミュレーション実行時に、このディレクトリにファイルが出力されますが、既に同名フ

ァイルが存在する場合、それらのファイルは上書きされますので注意してください26。

                                                  
25
 GEOに関しては使用法が異なります。３章１節『高速相互予測AFMシミュレータ』の説明をご覧ください。 

26 ただし、以前のファイルに対しては、”ファイル名~”というバックアップファイルが自動作成されます。 
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6 シミュレーション ６ シミュレーション 
 

█ 実行・再生・停止・一時停止                      

 

【実行・再生】 

 

 

 
 

Calculation/Replay Combo Box Start 
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1. “Tool Bar” → “Calculation/Replay Combo Box” → [Calculation/Replay] 

2. “Tool Bar” → [Start] 

 

まず“Calculation/Replay Combo Box”で、計算を行う27（Calculation）か、予め行われた計

算結果を再生（Replay）するかを決定します。次に、[Start]ボタンを押すと、計算／再生が

開始されます。実行中”Main View”上で、時々刻々変化する探針移動や試料の変形の様子を

見ることができます。また計算結果は可視化され”Result View”上に表示されます。シミュレ

ータからのメッセージは、”Log View”上に表示されます。 

 

【停止・一時停止】 

Progress Bar Stop Pause

 

1.“Tool Bar” → [Stop] or [Pause] 

再生開始後、[Start]ボタンが使用不可となり、[Stop]ボタンが使用可能となります。

[Stop]ボタンを押せば実行を停止します。[Pause]ボタンは再生の場合のみ使用可能です。こ

のボタンを押すことで、再生を一時停止できます。再開するには、再び[Start]ボタンを押し

ます。なおシミュレーションの進捗状況は、”Progress Bar”で見ることができます。 

                                                 

 

計算／

 
27 “Simulator Combo Box”で選択されたシミュレータが実行されます。 
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█ 結果表示                               

 

【表示データ選択】 

a Combo Box”内には、 ”Project Editor” →  “Simulator Tab” →  ”Output” → 

                                                 

 

1.“Result View” → [Result Data Combo Box] → 結果出力ファイル選択 

Result Data Combo Box 

 

”Result Dat

“Directory”以下に書かれている出力結果ファイルのリストが表示されます28。リストからデ

ータを選択すると、データ形式に応じて、グラフや濃淡図などが”Result View”上に描画され

ます。 

 

 

 
28 表示されるリストは、”Simulator Combo Box”で選択されるシミュレータに応じて変化します。 
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【数値表示】 

1.“Result View”右クリック → コンテクストメニュー → [Show Data]  

 

 

 

1.“Result View”右クリック → コンテクストメニュー → [Save As…] → “Save As”ダイア

ログ 

2. ファイル名入力 → [保存] 

【名前を付けて保存】
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この操作によって、結果出力ファイルを別名、および別の形式で保存できます。 

3D 表示】 

iew”右クリック → コンテクストメニュー → [3D-View] 

 

1.”Result View”右クリック → コンテクストメニュー 

 

【濃淡図

 
 

1.“Result V

 

【視点の変更】
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2. [Top/Front/Side] 

この操作を行うことで、真上（Top）、正面（Front）、真横（Side）に視点が変更されます。

Zoom All】 

的に拡大縮小および

 

ル→回転 

                                                 

また、Result View 上をドラッグすることにより視角を自由に変更することもできます。

[Shift]+ドラッグすることにより、視点を平行移動させることができます。 

 

【

 

1.”Result View”右クリック → コンテクストメニュー → [Zoom All]29

この操作によって、描画が”Result View”画面全体に収まるように、自動

平行移動が行われます。 

 

【拡大縮小】

1. マウスホイー

 
29 この操作は、“Tool Bar” → “Zoom All”ボタンをクリックすることによっても行えます。 
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マウスホイールを回転させることで、任意の倍率にスケーリングすることができます。 

 

はトグルボタンであり、この操作によって遠近法表示のオンオフを切り替える

 

 

【遠近法表示】

 

1. ”Result View”右クリック → コンテクストメニュー → [Perspective] 

 

[Perspective]

ことができます。 

 

【濃淡図断面図】
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1.“Result View”上ダブルクリック → 始点決定 

2.“Result View”上ダブルクリック → 終点決定 

3.“Result View”右クリック → コンテクストメニュー → [3D-View] 

4.“Result View”右クリック → コンテクストメニュー → [Cross-Section] → [Clipping] 
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７ 可視化設定 

 ７ 可視化設定 
 

█ コンポーネントの表示／非表示                     

 

以下では探針の場合を例にとって説明します。 

 

1.”Main View”右クリック → コンテクストメニュー → [Show Tip]30

 

試料、画像の表示／非表示も同様の操作で切り替えることができます。 

 

 

                                                  
30  [Show Tip] [Show Sample] [Show Image]は各々トグルボタンであり、繰り返しクリックすることでコンポーネン
トの表示／非表示を交互に切り替えられます。 
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█ 視点の変更・Zoom All・拡大縮小・遠近法表示                   

 

【視点の変更】 

Top Front Side 

 

1.”Main View”右クリック → コンテクストメニュー 

2. [Top/Front/Side] 

 

この操作を行うことで視角が変更され、真上（Top）、正面（Front）、真横（Side）から見た
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コンポーネントが描画されます。また、どのコンポーネントも選択していない状態で Main 

View 上をドラッグすることにより視角を自由に変更することもできます。[Shift]+ドラッグ

すること、あるいは x と z スライダーバーを動かすことにより、視点を平行移動させるこ

とができます。 

 

 

 

【Zoom All】 
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1.”Main View”右クリック → コンテクストメニュー → [Zoom All]31

                                                  
31 この操作は、“Tool Bar” → “Zoom All”ボタンをクリックすることによっても行えます。 
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この操作によって、コンポーネントが”Main View”画面全体に収まるように、自動的に拡大

縮小および平行移動が行われます。 

 

【拡大縮小】 

 

2. マウスホイール→回転 

マウスホイールを回転させることで、任意の倍率にスケーリングすることができます。 

 

【遠近法表示】 
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2. ”Main View”右クリック → コンテクストメニュー → [Perspective]32 

 
                                                  
32 [Perspective]はトグルボタンであり、この操作によって遠近法表示のオンオフを切り替えることができます。 
 

 67



 

█ View Option 設定                           

 

【分子描画法切り替え】33

Cartoon Ball 

 

Ball & StickDot 

1.”Main View”右クリック → コンテクストメニュー 

2.[View Option] → [Auto/Dot/Ball/Ball&Stick/Cartoon] 

 

                                                  
33
現在この操作を行えるのは、”～.pdb”、”～.xyz”、”～.txyz”の拡張子をもつコンポーネントデー

タのみとなっています。  
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この操作によって、分子の描画法を変更できます。[Auto]はコンポーネントデータから適切

な描画法を自動判定します。なお、これらの表示はファイル形式によって表示できないも

のがあります。Ball&Stick は原子間結合情報が必要で、Cartoon は PDB ファイルのみに対

応しています。 

 

【半透明／不透明切り替え】 
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1.”Main View”右クリック → コンテクストメニュー 

2.[View Option] → [transparent]34, 35

 

                                                  
34 [transparent]はトグルボタンであり、繰り返しクリックすることで不透明／半透明の表示を交互に切り替えられま
す。 
35 この操作は、”～.cube”、”～.csv”、”～.bmp”、”～.jpg”の拡張子をもつGrid形式のファイルに対して有効
です。 
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【等高線表示／非表示切り替え】 

 

 

1.”Main View”右クリック → コンテクストメニュー 

2.[View Option] → [with wire]36 37

                                                  
36  [with wire]はトグルボタンであり、繰り返しクリックすることで等高線の表示／非表示を交互に切り替えられます。 
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８ GUIの終了 
 ８ GUI の終了 
 

 

 
 

1.”Menu Bar” → [File] → [Quit] 

 

 

                                                                                                                                                  
37 この操作は、”～.cube”、”～.csv”、”～.bmp”、”～.jpg”の拡張子をもつ形式のファイルに対して有効です。 
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９ その他 

 ９ その他 
 

█ 画面の表示／非表示                          
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1.”Menu Bar” → [Display] → [Project Editor/Result View/Log View]38

以上の操作で画面の表示／非表示39の切り替えを行うことができます。また各画面上部の名

称（”Project Editor”など）が書かれているバーをダブルクリックすることで、GUIとの切り

離し／ドッキングが行えます。なお、”Main View”を非表示にすることや、GUIと切り離す

ことはできません。 

 

 

█ コンポーネントの選択                         

【選択】 

 

Component Combo 

 

                                                  
38 [Project Editor] [Result View] [Log View]はトグルボタンであり、繰り返しクリックすることで画面の表示／非
表示を交互に切り替えられます。 
39
非表示は、各画面上部の”×”印をクリックすることでも行えます。 
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1. a. ”Tool Bar” →”Component Combo” → コンポーネント名選択40

b. ”Project Editor”  → コンポーネント項目クリック 

c. ”Main View”  → コンポーネント周辺ダブルクリック41

 

1a、1b、1c いずれの方法でもコンポーネントを選択できます。コンポーネントが選択され

ると、”Main View”上で選択コンポーネントを囲む外枠の色が緑から赤に変化します。ある

コンポーネントが選択されている場合、マウスやスライダーバー、キーボードなどの操作

によって、そのコンポーネントの移動、回転を行えます。一方何も選択されていない場合、

同様の操作を行うと視点が変更されます。 

 

【選択解除】 

                                                  
40 “Project Editor”に表示されているコンポーネントのリストがここに表示されます。 
41 この方法で選択できるのは、”～.pdb”、”～.xyz”、”～.txyz”の拡張子をもつコンポーネントデータのみとな
っています。 
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1. a.”Tool Bar” →”Component Combo” →[No Selected] 

b.”Project Editor”  → “Component”クリック 

c.”Main View”  → 背景ダブルクリック 

 

1a、1b、1c いずれの方法でもコンポーネントの選択を解除できます。 

 

 

█ コンポーネントのデータベース登録                   

 

探針データは 

 “インストールディレクトリ¥data¥Tip¥” 
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試料データは 

 “インストールディレクトリ¥data¥Sample¥” 

以下にデータを直接コピーしてください。ここに登録されたデータは、探針用と試料用

の”DB View”に各々表示されます。なお登録は、”～.pdb”、 ”～.xyz”、 ”～.txyz”の拡張子を

もつコンポーネントデータのみ可能です。また、データと同名の画像ファイル（"データフ

ァイル名.gif”）を同じディレクトリに置いておくと、”DB View”にアイコンが表示されます。 

 

 

█ イメージの保存                            

 

【Main View 画面の保存】 

 

 

1.“Manu Bar”→ [File] → [Export Image] → “Save Capture”ダイアログ 

2. 画像ファイル名入力 → [保存] 

 

 77



 

【Result View 画面の保存】 

 

1.“Result View”右クリック → コンテクストメニュー 

2. [Export Image] → “Save Capture”ダイアログ 

3. 画像ファイル名入力 → [保存] 
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第 3 章 

計算事例 
 

 

この章では、SPM シミュレータに同梱されているサンプルデータファイルを使って、各シ

ミュレータに代表的な事例と、その計算方法をご紹介いたします。 

なお、ここで紹介されている図は実際のものと異なる場合がございます。 

 

 

1 探針・試料・測定 AFM 像予測シミュレータ １ 高速相互予測 AFM シミュレータ 
 

█ はじめに                               

 

「高速相互予測 AFM シミュレータ」は、探針の立体的な形状データ、試料表面の凹凸を表

現した形状データ、測定 AFM 像データ、の三種類のデータのうち、二種類のデータから、

残り一種類のデータを高速に予測するシミュレーションを実行します。このシミュレーシ

ョン計算では、探針－試料間の相互作用(ファンデルワールス力)は考慮されず、また、探針・

試料の 3 次元立体形状は変形しないと仮定して、純粋に幾何学的な計算により、データを

相互予測します。本シミュレーション計算では、カンチレバーは常に試料に接していると

仮定しており、いわゆる AFM のコンタクトモードの測定に対応しています。 
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本シミュレータは、古典論あるいは量子論の物理学的な方程式を一切考慮せず、探針、試

料、AFM 測定像を、単なる幾何学的な構造物としてとらえ、「測定中、探針は常に試料と接

触している」という仮定だけで、計算を行います。従って、量子論的な性質が支配的なミ

クロの領域での現象を調べるには、本シミュレータは、適していません。一方、ナノスケ

ールオーダーの半導体デバイスの AFM 像をシミュレートする、あるいは、高分子有機化合

物からなる生体試料の AFM による観察画像をシミュレートする、といった、マクロとミク

ロの中間的な領域のスケールでの用途に、本シミュレータは非常に適しています。 

 

以下に、本シミュレータの使用方法を、具体例を交えて説明します。高速相互予測 AFM シ

ミュレータ(以下、GeoAFM と略する)の使い方として、以下の三種類が考えられます。 

 

１．探針形状データ、試料表面形状データを元にして、測定 AFM 像データを求める。 

２．探針形状データ、測定 AFM 像データを元にして、試料表面形状データを求める。 

３．試料表面形状データ、測定 AFM 像データを元にして、探針形状データを求める。 

 

これらのシミュレーション方法を、順を追って見て行きます。 

 

█ 探針形状データおよび試料表面形状データから測定 AFM像データを求める  

 

ここでは、探針がピラミッド型のカンチレバーを使って、HOPG（Highly Oriented Pyrolytic 

Graphite：高配向熱分解黒鉛）上に配置された一個のラクトン系高分子量ポリマー(CLG：ε
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カプロラクトン・(L)ラクチド・グリコリド共重合体)の AFM 像を求めることにします。 

 

まず、新しいプロジェクトファイルを作成します。[File]→[New]をクリックすることにより、

[Create new project]というタイトルのボックスが現れます。[Project name]の欄は空欄にな

っています。ここでは、”test-geoafm001”という文字列を直接タイプ入力して、この名前の

プロジェクトファイルを作成することにします。 

 

なお、[Create new project]のボックスの、上から二つ目の項目[Directory]の欄には、本シミ

ュレータの実行ファイルが収められているディレクトリの絶対パスが、予め自動的に書き

込まれています。これは、[Directory]欄内に書き込まれている絶対パスの指定するディレク

トリの直下に、プロジェクト名と同じ名前のディレクトリが作られ、そのディレクトリ内

に、プロジェクトファイルを始めとする様々なデータファイルが自動的に収められること

を意味します。今の場合、このような設定の方が、シミュレーションに関係するデータフ

ァイルが、一か所にまとめられて便利なので、このまま[OK]をクリックします。 

 

次に、”Project Editor”の、”Setup”タブをクリックして選択します。ページの先頭の、項目

[Component]から、探針形状データ、試料表面形状データを、読み込むことにします。まず、

[Add Tip]の[Pyramid Model]を選択します。すると、ピラミッド形状の探針先端部分の角度

angle (deg)を要求するボックスが現れます。デフォルト値で 32.0 度が与えられていますの

で、ここでは、そのまま[OK]とします。次に、[Add Sample]の[Database]を選択します。す
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ると、予め用意された試料データの一覧が現れます。ここでは、[1clg-HOPG]を選択します。 

この時点で、ウィンドウは、以下のような画像を表示します。図の中央の水色の正方形が、

ピラミッド型探針を下から見上げた様子を表しています。縦に連なる鎖上の高分子構造、

基盤となるグラファイトの分子も、図に表示されていることが分かります。 

 

 

 

念のため、この段階で、プロジェクトファイルを保存することにします。[File]→[Save]で、

test-geoafm001.pro ファイルが保存されます。ある程度まとまった作業が完了するたびに、

このようにしてプロジェクトファイルの保存を行うことが可能です。 

 

これより、GeoAFM の計算実行に移ります。マウスを操作して、探針及び試料が表示され

ているウィンドウの適当な場所に、カーソルを配置し、そこで右クリックします。すると、

 82



下の図のように、縦長のコンテクストメニューが現れます。 

 

 

 

まず、シミュレータの画像解像度を設定します。コンテクストメニューの最も下の項目で

ある[GeoAFM]を選択し、さらに、[Set GeoAFM Resolution]をクリックします。これにより

解像度の数値を直接入力することが出来ます。解像度は、シミュレーション計算を行う際

の、長さの最小単位を表します。解像度は、Å単位で 0.1 以上の実数値を設定することが可

能です。値は、0.1 刻みで変化させることが可能です。また、解像度の最大値は 10 となっ

ています。なお、解像度のデフォルト値は 5[Å]に設定されています。 

 

ここでは、解像度を 1[Å]に設定してみましょう。なお、シミュレータの実際の運用では、

解像度の値は、実験で用いる AFM の解像度を参考にした値を、ユーザーが各自で設定する
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のが良いでしょう。また、本シミュレータを使用する際、サンプル全体の大きさに比べて、

非常に小さな値の解像度を取った場合、プログラムの演算処理量が急激に増大してしまい、

事実上、プログラムが止まってしまう(freeze してしまう)場合が有ります。従って、解像度

の決定は、十分な配慮の上で行って下さい。 

 

次に、再び、コンテクストメニューの最も下の項目である[GeoAFM]を選択し、さらに、[Show 

Simulated Image]をクリックします。すると、下図のように、ウィンドウ内に、オレンジ色

の等高線を表現した図が現れます。これが、予測される AFM 画像です。 

 

 

 

出来上がった予測 AFM 画像を見やすくするために、ウィンドウ内から、探針および試料の

画像を取り除くことにします。画像が表示されているウィンドウ内の適当な場所にカーソ
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ルを配置し、そこで右クリックします。縦長のコンテクストメニューが現れますので、メ

ニュー内の項目[Show Tip]および[Show Sample]を左クリックして、チェックを外します。 

 

これにより、ウィンドウ内には、予測される AFM 画像のみが表示された状態となります。

ウィンドウ画面内でカーソルをドラッグすると、画像は自由に立体的に回転しますので、

AFM 画像の凹凸が良く見える角度に視点を定めることが可能です。また、ウィンドウ上部

の虫眼鏡マークをクリックすると、画像がウィンドウ内に適切に収まるよう、自動的に画

像表示の拡大・縮小が行われます。例えば、以下の図のように、試料である高分子鎖の高

さの変化が良く見える角度に設定することが可能です。 

 

 

 

上で求められた予測 AFM 画像を、再利用可能なデータとして保存することにします。画像
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が表示されているウィンドウ内の適当な場所にカーソルを配置し、そこで右クリックしま

す。縦長のコンテクストメニューが現れますので、メニュー内の項目[GeoAFM]→[Export 

Simulated Data] を選択 します 。保 存ファ イル 名を要 求さ れます ので 、ここ では 、”

test-geoafm001 -image”と入力します。この結果、予測 AFM 画像は、test-geoafm001- 

image.cube というファイルに保存されます。 

 

以上の作業が終わったら、ひとまず、[File]→[Save]および[Close]として、プロジェクトを終

了させましょう。 

 

 

█ 探針形状データおよび測定 AFM像データから試料表面形状データを求める  

 

ここでは、ピラミッド型の探針形状データと、1clg-HOPG の測定 AFM 像データを元にして、

試料表面形状データを求める方法を説明します。測定 AFM 像データは、前の節において、

HOPG（Highly Oriented Pyrolytic Graphite：高配向熱分解黒鉛）上に配置された一個のラ

クトン系高分子量ポリマー(CLG：εカプロラクトン・(L)ラクチド・グリコリド共重合体)に

ついて計算して得られた、test-geoafm001-image.cube ファイルを用いることとします。 

まず、新しいプロジェクトファイルを作成します。[File]→[New]により、[Create new project]

ボックスを呼び出します。ここでは、[Project name]の空欄に、”test-geoafm002”という文字

列を直接タイプ入力して、この名前のプロジェクトファイルを作成することにします。 
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“Project Editor”の、”Setup”タブをクリックして選択します。まず、探針形状データを読み込

むことにします。ここでは、前と同じく、ピラミッド形状の探針を選択し、angle (deg)も

デフォルト値の 32.0 度とします。 

 

次に、測定 AFM 像データを読み込むことにします。前と同じく、Component という項目

を右クリックして、[Add Image]、さらに、[File]を選択します。ここで、前の節で作成した、

ディレクトリ test-geoafm001 内の test-geoafm001-image.cube という名前のファイルを選

択します。 

 

この時点で、ウィンドウは、以下のような画像を表示します。ただし、ここでは、ウィン

ドウ上部の虫眼鏡マークをクリックして、画像がウィンドウ内に適切に収まるよう、自動

的に拡大・縮小しています。 
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ここで、前に説明したのと同様の手順で、シミュレータの画像解像度を、1[Å]に設定します。

さらに、前で説明したときと同様に、 [GeoAFM]→[Show Simulated Sample]をクリックし

ます。すると、下図のように、ウィンドウ内に、緑色の等高線を表現した図が現れます。

これが、シミュレーションによって得られた、試料表面形状データです。(図では、緑色の

試料表面形状データの等高線と、オレンジ色の AFM 像データの等高線が、同時に表示され

ているため、黄色っぽい画像になっています。) 
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出来上がった試料表面形状の画像を見やすくするために、項目[Show Tip]および[Show 

Image]を左クリックしてチェックを外し、ウィンドウ内から、探針および AFM 像の画像を

取り除くことにします。これにより、ウィンドウ内には、試料表面形状データ画像のみが

表示された状態となります。試料画像を適切に立体回転、拡大・縮小して、以下の図のよ

うに、試料である高分子鎖の高さの変化が良く見える角度に設定することが可能です。 
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上で求められた試料表面形状データ画像を、再利用可能なデータとして保存することにし

ます。画像が表示されているウィンドウ内の適当な場所にカーソルを配置し、そこで右ク

リックします。縦長のコンテクストメニューが現れますので、メニュー内の項目[GeoAFM]

→[Export Simulated Data]を選択します。保存ファイル名を要求されますので、ここでは、”

test-geoafm002-sample ” と 入 力 し ま す 。 こ の 結 果 、 試 料 表 面 形 状 デ ー タ は 、

test-geoafm002-sample.cube というファイルに保存されます。 

 

 

█ 試料表面形状データおよび測定 AFM 像データから探針形状データを求める  

 

ここでは、1clg-HOPG の試料表面形状データ、および、測定 AFM 像データを元にして、探

針形状データを求める方法を説明します。測定 AFM 像データは、前の節において、HOPG
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（Highly Oriented Pyrolytic Graphite：高配向熱分解黒鉛）上に配置された一個のラクトン

系高分子量ポリマー(CLG：εカプロラクトン・(L)ラクチド・グリコリド共重合体)について

計算して得られた、test-geoafm001-image.cube ファイルを用いることとします。 

 

まず、新しいプロジェクトファイルを作成します。[File]→[New]により、[Create new project]

ボックスを呼び出します。ここでは、[Project name]の空欄に、”test-geoafm003”という文字

列を直接タイプ入力して、この名前のプロジェクトファイルを作成することにします。 

次に、[Add Sample]の[Database]を選択します。すると、予め用意された試料データの一覧

が現れます。ここでは、[1clg-HOPG]を選択します。 

 

次に、測定 AFM 像データを読み込むことにします。前と同じく、Component という項目

を右クリックして、[Add Image]、さらに、[File]を選択します。ここで、前の節で作成した、

ディレクトリ test-geoafm001 内の test-geoafm001-image.cube という名前のファイルを選

択します。 

 

この時点で、ウィンドウは、以下のような画像を表示します。 
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ここで、シミュレータの画像解像度を、1[Å]に設定します。さらに、[GeoAFM]→[Show 

Simulated Tip]をクリックします。出来上がった探針の画像を見やすくするために、ウィン

ドウ内から、試料および AFM 像の画像を取り除きます。これにより、以下の図のように、

ウィンドウ内には、探針形状データ画像のみが表示された状態となります。 
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上で求められた探針形状データ画像を、再利用可能なデータとして保存することにします。

画像が表示されているウィンドウ内の適当な場所にカーソルを配置し、そこで右クリック

します。縦長のコンテクストメニューが現れますので、メニュー内の項目[GeoAFM]→[Export 

Simulated Data] を選択 します 。保 存ファ イル 名を要 求さ れます ので 、ここ では 、”

test-geoafm003-tip”と入力します。この結果、試料表面形状データは、test-geoafm003- 

tip.cube というファイルに保存されます。 
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２ 連続弾性体 AFM シミュレータ ２ 連続弾性体 AFM シミュレータ 
 

█ はじめに                               

 

「連続弾性体 AFM シミュレータ」は、古典力学に基づき、探針－試料間でのファンデルワ

ールス力を考慮し、その上で、探針及び試料が弾性方程式に従うと仮定して、測定 AFM 像

を予測するシミュレーションを実行します。弾性方程式の解法としては、探針・試料を格

子分割した、有限要素法が用いられています。従って、実際のシミュレーション計算にお

いては、探針形状データおよび試料表面形状データを入力として、測定 AFM 像データを予

測・出力することになります。本シミュレータでは、カンチレバーの先端の探針は、試料

表面から数Å離れた状態で探針―試料間に働く相互作用を計算することになり、いわゆる

AFM のノンコンタクトモードの測定に対応しています。 

 

本シミュレータは、あくまで、電荷を帯びていない分子・原子間で働くファンデルワール

ス力を基本とした、古典力学で説明可能な現象を再現する、原子間力顕微鏡(AFM: Atomic 

Force Microscope)のシミュレータです。従って、原子・分子を直接観察するミクロスケー

ルの現象のシミュレーションには、本シミュレータは不向きと言えます。しかし、一方、

ナノスケールオーダーの半導体デバイスの AFM 像をシミュレートする、あるいは、高分子

有機化合物からなる生体試料の AFM による観察画像をシミュレートする、といった、マク

ロとミクロの中間的な領域での現象を調べる用途に、本シミュレータは非常に適していま
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す。 

 

前にも述べましたように、本シミュレータでは、純粋な量子力学的な効果は考慮されませ

ん。電子のトンネル現象を画像データに取り込む、いわゆる走査型トンネル顕微鏡(STM)

や、その他、様々な量子現象から物質の画像をとらえる走査型プローブ顕微鏡(SPM)のシミ

ュレーションは、本シミュレータの適用範囲外となります。(これら、量子力学的効果を取

り入れた SPM シミュレーションは、同梱されている「原子分子ナノ材料 AFM 像シミュレ

ータ」もしくは「量子論的 SPM 像シミュレータ」が適しています。) 

 

さらに、注意すべき事項としては、本シミュレータは、常に真空(もしくは室温大気中の)

環境下で、AFM 実験が行われていると仮定しています。液体中での AFM 像の再現機能は、

本シミュレータには含まれていません。(このような事例の解析には、「液中ソフトマテリア

ル AFM シミュレータ」が適しています。) 

 

█ 高分子量ポリマーの測定 AFM 像データ予測                

 

以下に、連続弾性体 AFM シミュレータ(以下、FemAFM と略する)の使用方法を、具体例を

元にして説明します。 

 

ここでは、探針がピラミッド型のカンチレバーを使って、HOPG（Highly Oriented Pyrolytic 

Graphite：高配向熱分解黒鉛）上に配置された一個のラクトン系高分子量ポリマー(CLG：ε
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カプロラクトン・(L)ラクチド・グリコリド共重合体)の AFM 像を求めることにします。た

だし、カンチレバーの先端の探針は、試料から一定の距離だけ離れていて、ノンコンタク

トモードで原子間力を検出するものと仮定します。 

 

まず、新しいプロジェクトファイルを作成します。[File]→[New]をクリックすることにより、

[Create new project]というタイトルのボックスが現れます。[Project name]の欄は空欄にな

っています。ここでは、”test-femafm001”という文字列を直接タイプ入力して、この名前の

プロジェクトファイルを作成することにします。 

 

次に、”Project Editor ”の、”Setup ”タブをクリックして選択します。ページの先頭の

[Component]という項目から、探針形状データ、試料表面形状データを、読み込むことにし

ます。まず、[Add Tip]の[Pyramid Model]を選択します。すると、ピラミッド形状の探針先

端部分の角度 angle (deg)を要求するボックスが現れます。デフォルト値で 32.0 度が与えら

れていますので、ここでは、そのまま[OK]とします。次に、[Add Sample]の[Database]を選

択します。すると、予め用意された試料データの一覧が現れます。ここでは、[1clg-HOPG]

を選択します。 

 

さらに、有限要素法の解像度を設定します。それには、ウィンドウの左側に表示されてい

る”Project Editor”の”FEM”タブを選択します。そのページに設定されている項目のうち、

[simulation]下の[resolution]の右隣の数値にカーソルを合わせて、左ダブルクリックして下さ
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い。これにより解像度の数値を直接入力することが出来ます。ここでは、2[Å]と設定します。 

 

解像度は、シミュレーション計算を行う際の、長さの最小単位を表します。もっと具体的

に述べると、試料および探針に対して有限要素法を行う際の、格子間隔を表しています。

解像度は、Å単位で 0.1 以上の実数値を設定することが可能です。値は、0.1 刻みで変化さ

せることが可能です。また、解像度の最大値は 10 となっています。なお、解像度のデフォ

ルト値は 2[Å]に設定されています。 

シミュレータの実際の運用では、解像度の値は、実験で用いる AFM の解像度を参考にした

値を、ユーザーが各自で設定するのが良いでしょう。 

 

この時点で、ウィンドウは、以下のような画像を表示します。 
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これより、探針先端部の走査(スキャン)する領域を指定します。まず、”Setup”タブを開いて、

[Sample]の[Size]の項目に注目します。試料の大きさが、幅 w：66.861[Å]、奥行き d：

156.464[Å]、高さ h：23.152[Å]であると、表示されています。 

 

そこで、探針が走査(スキャン)する領域を、幅 w：68[Å]、奥行き d：160[Å]と定めます。こ

れにより、試料全体が走査領域内に完全に含まれることになります。また、走査領域の縦

w=68[Å]、横 d=160[Å]の長さが、先ほど指定したシミュレーション解像度 2[Å]で割り切れる

値であることにも注意します。これにより、探針の走査範囲が、有限要素法の格子に丁度

の大きさで分割されることが保証されます。 

 

なお、この例では、走査範囲は、34×80 の格子に分割されています。一般に、格子サイズ

が 150×150 を超えると、一般的なパソコンの計算能力を超えることになり、計算時間が目

立って長くなり始めます。例えば、格子数が 200×200 のシミュレーションを行おうとする

と、たいていのパソコンは freeze してしまい、事実上、シミュレーションが不可能となっ

てしまいます。これらの点に注意して、resolution を設定することをお勧めします。 

試料の中央付近に、三次元空間の座標系の原点が設定されています。そこで、”Setup”のタ

グの[Tip]の項目の下の、[Position]、[ScanArea]の値を、以下のように直接入力します。 

[Position] x=-34, y=-80, z=28 

[ScanArea] w=68, d=160, h=0 
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ここで、以下の点に注意します。 

 

 [Tip][Position]の z の値は、[Sample][Size]の h の値より、十分大きな値を取った方が、有

限要素法のシミュレーション計算の実行が容易になります。試料の最大高さより、探針の

高さを十分大きく取らないと、原子間力相互作用の影響が大きくなり過ぎて、計算が不安

定になってしまう可能性があるからです。（探針と試料の間で働く原子間相互作用の力は、

距離の 6 乗に反比例するため、あまり、探針先端部分と試料とが接近し過ぎると、事実上

計算が不可能になる場合が有ります。） 

 

以上の設定の後、マウスを操作して、探針及び試料の画像が表示されているウィンドウの

適当な場所に、カーソルを配置し、そこで右クリックします。すると、縦長のコンテクス

トメニューが現れます。コンテクストメニューの [Show Scan Area]の項目にチェックを入

れると、ウィンドウは、以下のような画像を表示します。紫色の領域が、走査範囲となり

ます。 
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上記の準備の後、ウィンドウの上部のツールバーに配置されている項目を、 [FEM], 

[Calculation]として、三角形のボタンをクリックすると、シミュレーション計算が開始され

ます。最終的に得られる AFM 画像は、ツールバーの[Display]→[Result]で、以下のように表

示されます。 
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さらに、上記 AFM 画像を表示しているウィンドウ内にカーソルを配置して右クリックする

と、コンボボックスが現れ、そこで、[3D-View]を選択することが可能です。これにより、

以下の立体的な画像を得ることが出来ます。 

 

 

シミュレーションによって得られた AFM 画像についいて、以下の注意が必要です。それは、

試料表面上に与えられた数値が、高さを固定された探針先端の受ける力を表しており、試
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料表面の立体形状としての高さ(長さの次元を持つ物理量)を表現した値ではないというこ

とです。具体的には、AFM 画像の試料表面上の各点に与えられた値の単位は[N](ニュートン)

となります。 
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３ 液中ソフトマテリアル AFM シミュレータ ３ 液中ソフトマテリアル AFM シミュレータ 
 

█ はじめに                                 

 

ここでは、液中ソフトマテリアル AFM シミュレータで計算することのできる事例を紹介

いたします。現在まだ開発段階ですが、本シミュレータとしては以下のような計算を行う

ことができます。 

 

   ✎流体抗力、試料との接触応力を受けて稼動するカンチレバーの振動・変形 

✎探針が試料に接触した際に働く力 

   ✎カンチレバーの共鳴振動スペクトルの特性（開発中） 

 

 カンチレバーの根元を強制振動させると、カンチレバー全体が振動し周辺の流体が攪拌

され流れの場が生じます。そのた

め、レバーは流体の圧力や粘性力

を受けることになります。また、

レバーの先端に取り付けられた探針が粘弾性試料に接触した際には、その接触力も受けま

す。これらの力とレバー自身の弾性変形による応力のため、レバーの振動は複雑な動きに

なります。本シミュレータではゴム表面や細胞表面など比較的マクロスケールの粘弾性ソ

フトマテリアル試料の AFM 像計測をシミュレーションするのに適しております。 
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計算を実行するための初期条件として、大きく分けて、カンチレバー、液体、試料の３種

類の条件設定があります。各分類には下記のようなパラメータがあります。 

 

  ➢カンチレバーの設定 

    ・形状（長さ、幅、厚さ、傾き） 

・密度、縦弾性係数(ヤング率)、横弾性係数(ポアソン比) 

    ・振動モード(振幅，周波数，多重波，捩れ角度) 

        

➢流体の設定 

  ・物性（密度、動粘性率） 

 

➢ソフトマテリアル試料の設定 

・形状（高さ） 

・物性（ヤング率、ダンパー定数、メニスカス力） 

 

これらの条件設定を元に計算を実行すると、以下のようなものが結果として出力されます）。 

 

➢カンチレバーの各点での物理量の時間変化 

  ・上下振動：高さ、速度、傾き、流体抗力 

  ・捩れ振動：捩角、捩角速度、流体抗力モーメント 
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➢探針に働く力、探針に働くモーメント 

 

➢カンチレバーの各点での振幅 

 

※現在は、カンチレバー先端の高さの時間変化、振幅の時間変化、捩れ角度、探針が受け

る力の時間変化のみの出力に対応しております。 

 

今後は、ソフトマテリアル、及びバイオ系材料の SPM 計測での高速スキャンにも対応した

シミュレーションを可能にする予定です。 

 

█ 液中／真空中でのカンチレバーの動作                  

 

ここでは液中 AFM 像シミュレータで計算することのできる事例を、ソフトウェアに同梱し

ているプロジェクトファイルから選んで紹介いたします。 

液中もしくは、真空中でカンチレバーを振動させたときにどのような動きを示すのかを視

覚的に表示することができます。この計算で出力されるものは以下です。 

  

出力内容 ファイル名 ファイル形式 

カンチレバーの動画 
barmotion 

バイナリ 

探針の高さの時間変化 
height.dat 

テキスト（CSV） 
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カンチレバー各点の振幅の時間変化 
height_amplitude.dat 

テキスト（CSV）

探針に働く力 
tipforce.dat 

テキスト（CSV）

 

使用するプロジェクトファイルは 

SampleProject¥LIQ¥liquid¥liquid.pro 

です。ソフトウェアを起動して、このプロジェクトファイルを開いてください。すると、

project setting 画面は以下のようになります。 

 

 

 

 

                                 ① 

 

 

                                 ② 

 

 

 

 

                                  

 

 

 

 

                                 ③ 
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                                 ④ 

 

 

                                 ⑤ 

 

 

 

 

 

 

 

 

特に重要なものは赤枠で囲った箇所①～⑤で、大まかな意味は以下のとおりです。詳しく

はリファレンスマニュアルを参照してください。 

 

           ① 流体の設定 

           ② カンチレバーの物性に関する設定 

           ③ カンチレバーの振動に関する設定 

           ④ 試料の物性に関する設定 

           ⑤ 時間ステップ、計算の収束判定に関する設定 

 

なお、このプロジェクトファイルのカンチレバーの設定には、シリコンの物性値を予め入

力してあります（②の部分）。また、液中の計算は時間がかかるので、この⑤の数値を調節

することで計算時間の短縮を図ることができます。 
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次に、「Setup」タグを選択してください。 

ここで設定する箇所は、下図にある「DistanceFromSamples」の１箇所のみです。 

 

                         ⑥ 

 

 

⑥ 探針―試料間距離。単位[nm]。 

 

探針の下端と、試料の上端の距離をどのくらいにするか指定してください。カンチレバー

の振幅（③の [amplitude] の値）を考慮して探針を近づけすぎないようにご注意ください。 

※同梱してある[cubic.cube]ファイルが、プロジェクトファイルと同じフォルダに存在する

ことをご確認ください。無い場合はこの [DistanceFromSamples] の数値が変更できません。 

 

以上が液中シミュレーションをする場合の基本的な設定は終了です。 

真空中でのシミュレーションをする場合は以下のプロジェクトファイル、 

 

SampleProject¥LIQ¥vacuum¥vacuum.pro 

 

を使用してください。流体に関する設定<fluid>の項目がなくなっています。<fluid>以外

のその他の設定に関しては、液中計算の場合と同様に入力してください。 

 

初期設定が終了したら、シミュレーションを開始する前にメニューバーから[Display]―
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[Cantilever View]を選択してカンチレバーウィンドウを表示して下さい。 

スタートボタンを押して計算を開始すると下図のようにカンチレバーの運動の様子を動画

で見ることができます。 

 

 
 

また、穴の空いたカンチレバーのシミュレーションも用意しています。サンプルプロジェ

クトファイルは、 

SampleProject¥LIQ¥liquid_hole¥liquid_hole.pro 

 

です。この入力ファイルを使用してシミュレーションを行なうと以下のようなカンチレバ

ーの動きを見ることができます。 
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計算が開始されると、結果がファイルに次々と出力されます。まず、出力ファイル先のフ

ォルダに移動し、探針の高さファイル[height.dat]を開くと以下のようになっています。

なお、「***.dat」ファイルは CSV 形式ですので、お使いのテキストエディタ、もしくは

Microsoft Office Excel などを使用して開いてください。本シミュレータの結果表示機能

「Result View」では対応しておりませんのでご注意ください。 

 

‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐[height.dat]‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐ 

# scan parameters, 

# frequency  = 2.000000e+04 [Hz], ：周波数 

# amplitude  = 5.000000e‐09 [m],  ：振幅 

# baseheight = 5.000000e‐05 [m],  ：カンチレバー根元の高さ 

# interval   = 16,          ：カンチレバーの節点数 

# where      = head,         ：出力の箇所（ここでは先端：探針取付け位置） 

#, 

# 1:time,2:x,3:y,(4:value),   ：ラベル 1：時間, 2：探針 x 座標, 3：探針 y 座標, 4：値 

3.125000e‐06, +0.000000000000000e+00, +0.000000000000000e+00, +5.855273105931884e‐10, 

6.250000e‐06, +0.000000000000000e+00, +0.000000000000000e+00, +9.744593928917640e‐11, 

9.375000e‐06, +0.000000000000000e+00, +0.000000000000000e+00, +2.064622890038462e‐10, 

1.250000e‐05, +0.000000000000000e+00, +0.000000000000000e+00, +1.542440761237852e‐09, 
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・
・
・ 



 

  時間                             高さ 

‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐ 

 

先頭に「#」が書かれている部分はコメント欄で、どのような条件設定で計算したかが記録

してあります。コメント欄より下が実際の計算結果で、ラベルに書かれてあるように 

 

「#1.time, 2.x, 3.y, 4.value」 

 

の順で、探針高さの変化が時々刻々と出力されています。探針の高さは、「4.value」の列

を見てください。高さの単位は[m]で出力されています。ここで、探針の x 座標と探針の y

座標が「+0.00」になっていますが、丁度、探針の位置が原点ある状態で計算させた結果な

のでこのようになっています。 

 

時間とカンチレバー先端の高さの関係をグラフにする際は、上図の赤枠で囲った部分を別

途取り出して、お使いのグラフソフトで作成してください。 

次のグラフは、計算条件の違いによるカンチレバーの振動の時間変化をまとめたものです。

横軸：時間、縦軸：カンチレバー先端（探針位置）高さです。それぞれの線については、

赤線：真空中（試料なし）、緑線：真空中（弾性体試料あり）、青線：液中（弾性体試料あ

り）です。 

 

 111



vacuum-sample 

 

真空中で試料が無い場合は、きれいな正弦波を描いています（赤線）。試料は簡単な弾性体

を模擬していますが、探針が試料に接触すると力を受け、カンチレバーの挙動が大きく変

化する様子が分かります。 

 

同様に、探針が試料から受ける力についての出力ファイル[tipforce.dat]についても、

[height.dat]と同様の形式で書かれています。 

 

次に、カンチレバー先端の振幅の時間変化を記録したファイル[height_amplitude.dat]

を開いてください。 

 

‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐[height_amplitude.dat]‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐ 

# scan parameters, 

# frequency  = 2.500000e+04 [Hz],   ：周波数 

# amplitude  = 5.000000e‐09 [m],    ：振幅 
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# baseheight = 5.000000e‐05 [m],    ：カンチレバー根元の高さ 

# interval   = 16,           ：カンチレバーの節点数 

# where      = head,          ：出力の箇所（ここでは先端：探針取付け位置） 

#, 

# 1:time,2:x,3:y,(4:real),(5:imag),(6:arg),(7:abs),  ：ラベル 

（1.時間, 2.探針x座標, 3. 探針y座標, 4.実部, 5.虚部, 6.角度[rad], 7.振幅の絶対値） 

1.250000e‐06, ・・・・・・・・・・・・ ,+8.394009779916932e‐02,+1.970401390391217e‐13, 

2.500000e‐06, ・・・・・・・・・・・・ ,+1.804759500951036e‐01,+1.223363488802055e‐12, 

3.750000e‐06, ・・・・・・・・・・・・ ,+2.703654947460822e‐01,+3.550824553010788e‐12, 
・
・
・ 

 

 

‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐ 

 

計算結果は、 

 

「# 1:time,2:x,3:y,(4:real),(5:imag),(6:arg),(7:abs)」 

 

の順で記録されています。上記 4～7 の関係は 

real=abs*cos(arg), imag=abs*sin(arg) 

です。カンチレバー先端の振幅は、[7.abs]の列を見てください。振幅の単位は[m]です。

先程と同様にグラフを作成すると以下のようになります。 
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計算が進むにしたがって、カンチレバーの振動の振幅が一定値に収束していく様子が分か

ります。初期条件設定によっては振幅が収束せず、発散する場合がございますのでご注意

ください。 

 

 

█ カンチレバーの周波数特性 ―共鳴曲線―                   

 

前節での計算結果を利用して、カンチレバーの周波数特性を計算した例をご紹介します。

具体的には、カンチレバーをさまざまな周波数で振動させてみて、その振動振幅がどう変

化するのかをグラフにプロットして共鳴曲線を作成しました。 

計算するための測定環境は水中、真空中で、それぞれカンチレバーの根元の振動周波数を

変更しながら、レバー先端（探針取付け位置）の振動の時間変化を計算しました。振動の
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振幅がある程度収束するまで計算するために、ここでは時間ステップの設定を変更してカ

ンチレバーの振動回数を増やします。 

計算結果について、周波数と振動振幅の関係をグラフにまとめることでカンチレバーの動

作特性が得られます。使用する出力ファイルは、[height_amplitude.dat]です。その様

子を下図に示します。横軸：周波数、縦軸：振幅で、赤線：真空中、緑線：空気中、青線：

水中での共鳴曲線を表しています。 

水中でシミュレーションした場合の共振周波数が、真空中及び空気中で計算した値より小

さくなっている様子が分かります。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

このように、カンチレバーの物性値、測定環境等の条件を入力して計算し、周波数特性を

導き出すことができ、実際のカンチレバーの設計を検討する際にも役立ちます。 
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４ 原子分子ナノ材料 AFM 像シミュレータ ４ 原子分子ナノ材料 AFM 像シミュレータ 
 

█ はじめに                               

 

この節では「原子分子ナノ材料 AFM 像シミュレータ」で計算することのできる事例を、

ソフトウェアに同梱しているプロジェクトファイルから選んで、紹介いたします。このシ

ミュレータでは探針を試料に近づけることによる試料分子の変形を考慮したシミュレーシ

ョンが可能です。試料分子の変形は、計算手法の違いによって、次の二種の計算モードを

選択することができます。 

 

1. 構造最適化 AFM 像シミュレータ・・・分子内部のエネルギーが最小になるような

原子配置を探索することにより、安定な分子構造を求める方法 

2. 分子動力学 AFM 像シミュレータ・・・原子一つ一つについてニュートンの運動方

程式を解くことにより、分子構造の時間変化を求める方法 

 

このシミュレータでの計算手順は大まかには以下のような流れになっています。 

 

i. 探針モデルと試料モデルを配置する(Setup タブでの設定) 

ii. その他の入力パラメータを設定する(各シミュレータのタブでの設定) 

iii. 計算を実行する 

iv. 計算終了後、結果を見る 
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なお、計算に必要な入力パラメータの詳細な説明につきましては、「リファレンスマニュア

ル」を参照してください。 

 

 

█ ペンタセンの周波数シフト像計算の例                  

 

構造最適化 AFM 像シミュレータによる、有機分子試料を対象とした原子分解能 AFM 計

算 の 例 を 紹 介 し ま す 。 ( こ こ で 紹 介 し て い る 例 は プ ロ ジ ェ ク ト フ ァ イ ル

SampleProject¥CG¥NC_pentacene¥NC_pentacene.pro に対応しています。) 

探針には、先を CO で修飾したものを想定し CO 分子を用い、試料はペンタセン分子で

す。ここでは、ペンタセン分子は構造が変化しないとして、各原子の座標は固定するよう

に設定します。 
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入力パラメータの設定は画面左の”Project Editor”で行います。主なパラメータ設定項目は

次の通りです。(詳細は「リファレンスマニュアル」を参照ください) 

 

 探針の走査開始位置 

 探針の走査範囲(Setup → Tip → ScanArea) 

 スキャンモード(CG → Tip_Control → scanmode) 

 解像度(CG → Tip_Control → delta_xy) 

 探針の振幅(CG → Tip_Control → NC_Mode_Setting → TipZamplitude) 

 カンチレバーのバネ定数(CG → Tip_Control → NC_Mode_Setting → SpringConst) 

 共鳴周波数(CG → Tip_Control → NC_Mode_Setting → ResoFreq) 
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この計算設定条件による周波数シフト像のシミュレーション結果は、Result ビューで参照

することができます。(メニュー → Display → Result を選択し、表示された Result ビュー

画面上部のボックスから”test_frq.csv”を選択) 

 

 
 

 

█ アルカン分子のフォースカーブ計算の例                 

 

分子動力学 AFM 像シミュレータによる、有機分子試料を対象とした試料分子の変形とフ

ォースカーブを予測する計算例を紹介します。(ここで紹介する例はプロジェクトファイル
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SampleProject¥MD¥FCurve_octane4¥FCurve_octane4.pro に対応しています。) 

探針にはカーボンナノチューブを想定し、試料にはオクタン４分子を用います。ここで

は、オクタン分子の一方の端が基盤に固定されていると考え、端の原子を固定するように

設定し、４つの分子を並べて配置します。固定した原子とは反対の方向からカーボンナノ

チューブ探針を近づけ、探針に作用する力を計算します。 

 

 
 

入力パラメータの設定は画面左の”Project Editor”で行います。主なパラメータ設定項目は

次の通りです。(詳細は「リファレンスマニュアル」を参照ください) 

 

① 探針の移動開始位置(Setup → Tip → Position ) 

② 探針の移動範囲(Setup → Tip → ScanArea -> h) 

③ 各試料の位置(Setup → Sample → Position ) 
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④ スキャンモード(MD → Tip_Control → scanmode) 

⑤ 解像度(MD → Tip_Control → delta_z) 

⑥ 時間刻み幅(MD → MD_Setting → TimeStep) 

⑦ 探針位置あたりの計算ステップ数(MD → MD_Setting → StepNumber) 

⑧ 温度(MD → MD_Setting → Temperature) 

 
 

この計算設定条件によるフォースカーブのシミュレーション結果は、Result ビューで参照

することができます。(メニュー → Display → Result を選択し、表示された Result ビュー

画面上部のボックスから”test_fz.csv”を選択)) 
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Replay を選択し再生することにより見るこ

とができます。 

フォースカーブ計算中の探針と試料の動きは、
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５ 量子論的 SPM シミュレータ ５ 量子論的 SPM 像シミュレータ 
 

█ はじめに                               

 

この節では「量子論的 SPM 像シミュレータ」で計算することのできる事例を、ソフトウ

ェアに同梱しているプロジェクトファイルから選んで、紹介いたします。「量子論的 SPM

像シミュレータ」での計算手順は大まかには以下のような流れになっています。 

 

i. 探針モデルと試料モデルを配置する(Setup タブでの設定) 

ii. その他の入力パラメータを設定する(DFTB タブでの設定) 

iii. 実行を開始する 

iv. 計算終了後、結果を見る 

 

グラフィカルユーザーインターフェースの具体的な操作方法、および、計算に必要な入力

パラメータの説明につきましては、「リファレンスマニュアル」を参照してください。 

 

 

█ AFM（周波数シフト像）計算の例                     
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はじ シフト

像 の 予 測 )

の 例 を紹介

し ま す。(こ

の 例 は同梱

さ れ ている

プ ロ ジェク

ト イル

SampleProject¥DFTB¥afm_hsi¥afm_hsi.pro によるものです。) 他のシミュレータでは行う

ことのできない精密な AFM シミュレーションを必要とする場合にご利用ください。 

探針は、水素が吸着したシリコン探針の先端をモデル化したものであり、試料は水素終

めに、本ソフトウェアの他のシミュレータにも備わっている AFM 計算(周波数

フ ァ

端

タは以下の図の通りです。特に重要なものは赤枠で囲

っ

査範囲の始点 

。周波数シフト像を計算する際にはタグ h の値を 0 よ

Si

H

されたシリコン(001)表面です。 

この計算例で注意すべきパラメー

た箇所で、大まかな意味は以下のとおりです。(別の系の計算を行う場合、囲っていない

箇所のパラメータも注意する必要があります。詳しくは「リファレンスマニュアル」を参

照してください。) 

①. 探針走

②. 探針走査範囲のサイズ
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り大きくしてください。 

計算モード。DFTB_AFM を③. 選択してください。 

ータ 

とはできません。 

き、以下のようになります。(カラーバーを逆転させています)。設定した探針試料間距離の

場合、水素が置かれている位置では引力が強くなり周波数シフトの絶対量が大きくなるこ

④. カンチレバーの物理パラメータ 

⑤. 探針のマクロ形状に関するパラメ

(注) 現時点では構造緩和計算を取り入れるこ

 

 

この設定による周波数シフト像のシミュレーション結果は Result ビューでみることがで

 ①

③

④

⑤

②
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とが分かります。 

 

 
 

 

█ STM 計算の例                            

 

（１）トンネル電流像の計算 

次に、本ソフトウェアの他のシミュレータには備わっていない STM 計算の例を二つ紹介

します。一つ目はトンネル電流像の予測例を紹介します。(この例は同梱されているプロジ

ェ

 

クトファイル SampleProject¥DFTB¥stm_hsi¥stm_hsi.pro によるものです。) 

探針はシリコン探針の先端をモデル化したものであり、試料は水素終端されたシリコン

(001)表面から水素を一つ取り除いたものです。 
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H

Si

この列の H が一つ少ない 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

この計算例で注意すべきパラメータは以下の図の通りです。特に重要なものは赤枠で

った箇所で、大まかな意味は以下のとおりです。(別の系の計算を行う場合、囲っていな

囲

い

箇

①. 探針走査範囲の始点 

②. 探針走査範囲のサイズ。タグ h の値は 0 として扱われます。 

TM を選択してください。 

されます。) 

所のパラメータも注意する必要があります。詳しくは「リファレンスマニュアル」を参

照してください。) 

 

③. 計算モード。DFTB_S

④. 探針の電位(STM モードでは minimum に指定した値のみで計算
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以下のようになります。(カラーバーを逆転させています)。水素が抜けている位置にダ

ン

トンネル電流像の計算事例は、この他に、シリコン探針先端とシリコン(111) DAS 7x7 表

面 SampleProject¥DFTB¥stm_das7¥stm_das7.pro)、および、フラーレン探針とシリコン

(1

 
 

この設定によるトンネル電流像のシミュレーション結果は Result ビューでみることがで

①

③

②

④

き、

グリングボンドがあることにより、電流値が大きくなることが分かります。 

 

(

11) DAS 7x7 表面(SampleProject¥DFTB¥stm_das7_c60¥stm_das7_c60.pro)を同梱し

ております。 
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（２）STSの計算 

STM 計算の例の二つ目としてトンネル電流分光の計算例を紹介します。(この例は同梱さ

トファイル SampleProject¥DFTB¥sts_das7¥sts_das7.pro によるも

の

れているプロジェク

です。) 

探針はシリコン探針先端をモデル化したものであり、試料はシリコン(111) DAS 7x7 表面

です。 

 

 129



 

この計算例で注意すべきパラメータは以下の図の通りです。特に重要なものは赤枠で囲

った箇所で、大まかな意味は以下のとおりです。(別の系の計算を行う場合、囲っていない

箇所のパラメータも注意する必要があります。詳しくは「リファレンスマニュアル」を参

照してください。) 

 

①. 探針の位置(STS モードではこの位置でのみ計算が行われます。) 

②. 計算モード。DFTB_STS を選択してください。 

③. 探針の電位(最小値、最大値、分割数) 
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①

③

②

 

 

この設定によるトンネル電流スペクトルの計算結果は Result ビューでみることができ、

以下のようになります。左図が電流電圧カーブ、右図がスペクトル[(dI/dV)/(I/V)の値]です。

横軸の電圧は試料に対する探針での値です。 
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█ KPFM 計算の例                            

 

最後に KPFM 計算(接触電位差像の予測)の例を紹介します。(この例は同梱されているプ

ロジェクトファイル SampleProject¥DFTB¥kpfm_c6¥kpfm_c6.pro によるものです。) 

探針は、水素が吸着したシリコン探針の先端をモデル化したものであり、試料はシリコ

ン(001)-c(4x2)表面です。 
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この計算例で注意すべきパラメータは以下の図の通りです。特に重要なものは赤枠で囲

った箇所で、大まかな意味は以下のとおりです。(別の系の計算を行う場合、囲っていない

箇所のパラメータも注意する必要があります。詳しくはパラメータマニュアルを参照して

ください。) 

 

①. 探針走査範囲の始点 

②. 探針走査範囲のサイズ。タグ h の値は 0 として扱われます。 

③. 計算モード。DFTB_KPFM を選択してください。 

④. 探針の電荷中性度(最小値、最大値、分割数)  

注) 採用している計算モデルの都合上、電位差での指定は行えません。 
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①

③

④

②

この設定による接触電位差像のシミュレーション結果は Result ビューでみることができ、

以下のようになります。表面のアップダイマーを繋ぐようにした電位差の大きい領域が見

られます。 

接触電位差像の計算事例は、この他に、上記と同じ探針/試料モデルで探針試料間距離を

短くしたもの(SampleProject¥DFTB¥kpfm_c4¥kpfm_c4.pro)、および、試料表面に不純物

を 入 れ た も の (SampleProject¥DFTB¥kpfm_n6¥kpfm_n6.pro と SampleProject¥DFTB 

¥kpfm_n4¥kpfm_n4.pro)を同梱しております。 
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第 4 章 

試料モデリング機能 
 

 

この章では、SPM シミュレータで用いる試料構造を作成するための補助ツールの使い方を

ご紹介いたします。現在この補助ツールは、「１．半導体薄膜モデリング」、「２．分子モデ

リング」の大きく２つの機能に分かれております。 

両者ともにグラフィカル・ユーザー・インターフェイス（GUI）を備えており、ユーザーが

視覚的に試料構造データを作成することが可能となっております。 

 

 

１．半導体薄膜モデリング １ 半導体薄膜モデリング 
 

█ はじめに                               

 

ここでは、SPM シミュレータの補助機能であるモデリング機能を利用した、半導体試料表

面の初期構造の作成の方法について記述します。この機能では、ミクロスケール（DFTB・

CG・MD）で使用される原子モデルを作成しますが、一部マクロスケールでも使用するこ

とができます。ミクロスケールで使用される原子モデルとして、理想表面を持つ薄膜モデ

ルが作成されます。また、任意の原子の追加・削除・移動の編集を行う事ができます。 
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█ 実行の方法と GUI の概要                        

 

mkatmstruct.exe という実行ファイルをダブルクリックすると、下のような GUI が立ち上

がります。この GUI は４つの部分から構成されています。一番上にツールバー、左側に各

種パラメータの入力部、右側上部に原子モデルの表示部、右側下部にテキストの出力部が

配置されています。ユーザーからの要求はパラメータ入力部から入力します。入力に従っ

て作成した原子モデルは原子モデルの表示部に表示され、追記事項はテキスト出力部へ出

力されます。作成した原子モデルは DFTB 形式（xyz 形式）で指定されたファイル名に保存

されます。 

 

 

ツ ルバ

 

テキスト出力部 

 

 

 

 

 

原子構造表示部 

 

 

 

 

 

 

 

 

パラメータ入力部 
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█ シリコン（００１）表面の作成方法                   

 

薄膜モデルを作成するために必要な情報は、作成したい物質の名称と、その結晶データ（空

間群・格子定数・既約原子位置）、およびミラー指数とスーパーセルの単位胞数です。これ

らの情報は、論文やウェブ上で公開されているもの等から得ることができます。 

 

ここでは、シリコン（００１）の新規に作成する方法を説明します。新規で作成する場合

は、まず始めにメニューバーの”File”から”New”を選択します。”New”が選択されると、GUI

はパラメータ入力部に新しいタブ”Make Surface”を表示します。このタブに結晶データを入

力してください。入力部最上段の”Title”フォームには、ご希望のタイトルを入力してくださ

い。ここでは例として”Si001”とします。ここで、全てのフォームへの入力は半角英数字を

使用されることを推奨します。 

 

二番目のフォームでは空間群の指定を行いま

す。”Table No.”のボタンをクリックすると、ポ

ップアップウィンドウが立ち上がり空間群の

リストが表示されます。適切な空間群を選択し

てクリックしてください。あるいは空間群の番

号を直接タイプすることでも入力可能です。こ
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こでは、シリコンの面心立方構造を想定していますので、227 とタイプします。OK をクリ

ックすると本ウィンドウは閉じ、空間群の入力が完了します。 

 

三番目のフォームでは、格子定数を入力します。それぞれÅと度の単位で直接タイプして入

力してください。シリコンの場合は、5.4, 5.4, 5.4, 90.0, 90.0 90.0 となりますが、対称性

から格子定数 a のみを入力するように制限がかかっています。 

 

 

次に原子の既約な座標を入力します。入力はまず”Atom”ボタンをクリックすることで、右

のようなウィンドウが立ち上がります。適切な原子種を選択してください。OK をクリック

することで、原子名フォームに原子記号が入力され、座標の入力を求めてきます。座標を

入力し、その下の”Add”ボタンでリストに追加さ

れます。以下、必要な情報の量だけ同じ作業を

繰り返します。入力に失敗した場合、その行を

指定し、”Modify”で訂正、”Delete”で削除するこ

とができます。また”Clea all”でリストの全ての

情報を削除することができます。 

シリコンの場合は、ブラベー格子内に存在する

原子数は 8 個ですが、既約原子座標はひとつですので、Si, 0.0, 0.0, 0.0 を入力すれば完了

です。 
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以上で、結晶としての情報を入力することができました。薄膜モデルを作成するためには、

さらに、表面に現れる面の情報と薄膜のサイズの入力が必要となります。表面に現れる面

の指定はミラー指数によって行われます。ご希望の面を表すミラー指数を”Miller index”フォ

ームにタイプして下さい。隣の”Number of cells”フォームでは、薄膜モデルのサイズの指定

を行います。それぞれ x,y,z 方向へ指定した数だけ結晶情報から得られる単位胞を並べてス

ーパーセルを作成します。 

ここでは、Si(001)表面ですので、ミラー指数には 0,0,1 を入力します。スーパーセルのサイ

ズは、1 から 3 のあたりで入力されると、DFTB の計算コストに似合うモデルが作成できま

す。ここでは、例として 3,3,1 と入力します。 

 

最後に、”Make XYZ”ボタンをクリックしてください。正常に処理されますと、原子構造表

示部に、シリコン表面を表す薄膜モデルの原子構造が表示されます。またテキスト出力部

には、この薄膜モデルにおける並進ベクトルが表示されます。 

 

原子模型の表示と同時に、パラメータ入力部のタブは、”XYZ Editor”をハイライトします。

これにより個々の原子を編集することができます。詳細は６．「個々の原子座標の編集」を

参照してください。”xyz”ファイルの保存は、メニューバーの”File”から”save”を選択してく

ださい。ファイル名の指定を要求してきますので、適切なファイル名を入力して”save”をク

リックしてください。 
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█ シリコン（１１１）表面の作成方法                   

 

ここでは、シリコン（１１１）の薄膜モデルを作成する方法を説明します。 

同じシリコンですので、結晶を表す情報はすべて同様です。同様の作業を繰り返して下さ

い。ただし”Title”は変更することを推奨します。ここでは、”Si111”とします。 

次にミラー指数を変更します。”Miller index”フォームに 1,1,1 を直接タイプします。最後に、

出力ファイル名を指定して、実行ボタンをクリックします。ファイル名は、たとえ

ば”si111.xyz”と変更します。原子構造表示画面で最終確認をします。 

テキスト出力画面に、この薄膜モデルにおける並進ベクトルが表示されていますので、SPM

シミュレータの DFTB 法で計算される場合は、この値を適切なフォーム（プロジェクトエ
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ディタの DFTB タグ内、下の方）へコピーアンドペーストして下さい。 

 

 

█ グラファイト（０００１）表面の作成方法                

 

グラファイトの結晶の情報は、以下の通りです。 

 

格子定数 a=2.464, b=2.464, c=6.711, α=90.0, β=90.0, γ=120.0 

空間群 194 (P 63/m m c) 

原子位置 C1, 0.000, 0.000, 0.250 

  C2, 0.333, 0.666, 0.250 

 

ミラー指数の表示は、六方晶・三方晶の場合、3 つではなく 4 つの整数によって表されるこ

とが多いのですが、後者の場合独立な数字は 3 つですので、ここでは 3 つの整数によって

指定して頂くようにしています。(0001)表面の場合は、(001)を入力してください。基本的

には、3 番目の数字が省略されています。あとはシリコンと同様に処理してください。 

 

 

█ 個々の原子座標の編集                         

 

この機能では、作成した原子モデルの個々の原子を編集することができます。一番上のフ

ォームは、この原子模型に新しい原子を追加する場合に使用します。二番目のフォームは、

すでにある原子を編集する場合に使用します。最後のフォームには、現在ある原子構造の
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原子座標の情報が表示されています。 

新しい原子を加えるときは、”Add/Delete”フォ

ームに適切な原子名と座標を入力し、”Add”ボ

タンをクリックしてください。原子を削除した

い場合は、削除したい原子を一番下の欄（ある

いは原子構造）から選択して”Delete”ボタンを

クリックしてください。コピーも同様に行う事

が出来ますが、同じ原子座標に重ならないよう

に注意してください。 

原子位置の変更についてもほぼ同様で、編集し

たい原子をクリックして指定し、変更したい情報を”Modify”フォームに入力したのち

に、”Atom change”, “Move”, “Set pos”のいずれかのボタンをクリックしてください。”Atom 

change”ｄは原子の変更、”Move”では移動（現在の位置からの相対座標）、”Set pos”では座

標の再指定（絶対座標）を行います。編集が終了し画面での確認がとれましたら、”xyz”フ

ァイルへ保存して、終了してください。 

 
 
 

█ 既存の xyz ファイルの個々の原子座標の編集                    
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既存の”xyz”ファイルについても個々の原子を編集することができます。メニューバー

の”File”から”Open”を選択してください。ファイルの指定を要求しますので、適切なファイ

ル名を指定して”Open”をクリックしてください。原子構造表示画面に原子構造が表示され

るとともに、入力部の”XYZ Editor”に原子座標に関する情報が表示されます。 

 

 

█ SPM シミュレータでの利用方法                           

 

モデリングツールからの出力は主に 2 つで、ひとつは原子座標を格納した”xyz”ファイルで

す。これを任意の場所へ保存し、SPM シミュレータで新規サンプルとして読み込むことで

利用可能です。また、DFTB 法の試料表面として使用するときは、並進ベクトルが必要にな

りますので、テキスト出力部に出力される並進ベクトルを SPM シミュレータの所定のフォ

ームへコピーアンドペーストすることによって利用してください。現バージョンでは自動

受け渡しができません。 
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２．分子モデリング ２ 分子モデリング 
 

█ はじめに                               

 

ここでは、SPM シミュレータの初期構造を作成するためのツールとして、フリーソフト

ChemSketch と OpenBabel の使用方法を紹介いたします。このツールで作成した初期構造

データは、原子・分子・ナノ材料 AFM シミュレータで利用可能です。 

原子・分子・ナノ材料 AFM シミュレータでは、AFM 像のシミュレーションを行うために、

Allinger によって開発された MM3 という古典力場パラメータを用いています。MM3 が対応

している元素を下図に示します。 

 

MM3 力場対応元素

 

 

パラメータは元素だけではなく、その元素がどのような化学的な環境にあるかによっても
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区別して設定され、その区別のことを原子種(atom type)といいます(例えば、炭素元素に対

して、アルキル基の炭素とベンゼン環の炭素とは区別されるため、異なる原子種です)。つ

まり、原子種、およびそれらの組み合わせによって、vdW 相互作用や二原子間の共有結合

の相互作用等のパラメータが設定されることになります。考えうる原子種の組み合わせは

非常に多いため、分子構造によってはパラメータが用意されておらず、その場合は分子内

の構造変化の計算を行うことができません。 

█ ChemSketch のダウンロード                     

 

ACD/ChemSketch は Advanced Chemistry Development 社の提供するフリーソフトです。

こちらのソフトウェアのダウンロードにはユーザー登録が必要であり、また、ライセンス

条 項 に 同 意 の 上 で イ ン ス ト ー ル を 行 っ て い た だ く 必 要 が あ り ま す 。 以 下 に 、

ACD/ChemSketch のダウンロードを行う流れの一例をご紹介いたします。 

 

①URL: http://www.acdlabs.com/resources/freeware/chemsketch/

の ACD/ChemSketch のダウンロードページを表示します。 

②ページの下部にあるダウンロードのアイコンをクリックします。 

③ログインページが表示されるので、Create an Account をクリックします。 

④下図が表示されるので*の印がついている項目を入力し、Register をクリックします。 

 

 

 146



 

性別 
下の名前 苗字 

確認のため同じ E-Mail 

アドレスを再度入力 

確認のため同じ 

パスワードを再度入力 

郵便番号 
国籍 

会社名 

 

 

 

⑤記入した E-Mail アドレス宛に、メールが届いたら 

Before you can login you need to activate your account: 

To automatically activate your account, click here

とメール本文に記載されているので、青く反転したhereをクリックします。 
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これでアカウントの作成は終了です。 

⑥再度URL: http://www.acdlabs.com/resources/freeware/chemsketch/

の web ページを表示します。 

⑦ページの下のほうにあるダウンロードのアイコンをクリックします。 

⑧ログインページが表示されるので、手順④で入力した E-Mail アドレスとパスワードを

入力し Login アイコンをクリックします。 

⑨下図が表示されたら実行をクリックします。 

 

 
 

⑩Next > をクリック 
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⑪ライセンス条項を確認したうえで、 I accept the terms in the License Agreement を選

択し、Next >をクリック。 
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⑫Next >をクリック。 
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⑬Next >をクリック。 
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⑭Next >をクリック。 

 

⑮Install をクリック。 
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⑯Finish をクリック。 
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⑰ChemSketch をクリック。 

 

⑱OK をクリック。 
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⑲Select All をクリックし、Yes をクリック。 

 

⑳OK をクリック。 

 

以上でダウンロードと初期設定は終了です。 
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█ OpenBabel のダウンロード                      

 

OpenBabel は GPL ライセンスのもとで配布されているフリーソフトであり、化学情報のフ

ァイル形式の変換に用いられます。使用には、こちらのソフトウェアのライセンス条項に

同意の上でインストールを行っていただく必要があります。以下に、OpenBabel のダウン

ロードを行う流れの一例をご紹介いたします。 

 

① URL:http://openbabel.org/wiki/Main_Page  
の webページを表示します。 

② Download をクリック。 

 

 

③ Download v2.3.0 Installer をクリック。 
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④ 実行をクリック。 

 

 

⑤ 実行するをクリック。 

 
 

⑥ Next >をクリック。 
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⑦ ライセンス条項を確認したうえで、I Agree をクリック。 

 
 

⑧ Next > をクリック。 
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⑨ Installをクリック。 

 
⑩ Finishをクリック。 
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以上でダウンロードは終了です。 

 

 

█ ChemSketch を用いたオクタン分子の作成                

 

炭素数８のアルカンである、オクタン(分子式C8H18)を作成します。 １） 
３） 

 

２） 

“ChemSketch”を起動 

１． 炭素鎖の作成 

１）”Structure”を選択 

２）”Carbon”を選択 

３）”Draw Normal”を選択 
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４）白画面にカーソルを合わせます。 

５）クリックすると CH4 が生成されます。 

 

 

 

 

 

 

 

 

 

６）CH4 にカーソルを合わせ、クリックすると、

CH3 が一つ付加されます。 

 

 

７）片方の端の CH3 にカーソルを合わせます。 

 

 

 

 

８）クリックすると炭素が一つ付加されます。 

 

 

 

４） ５） 
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９）炭素の数が８個になるまで、7)－8)を繰り返します。 

 

 

 

 

 

 

 

３． ”3D Optimization”ボタンをクリックすると、水素原子が付加されて三次元構造がでます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

クリック 

４． ファイルの出力 

 

１）”File”メニュー内の”Save As”をクリック 

２）”ファイルの種類”を”MDL Molfiles [V2000]”に設定し、ファイル名を入力して保存し

ます。 
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█ Open Babel を用いたファイル形式の変換                

 

“Open Babel”を用いて、“ChemSketch”で作成したファイル(mol 形式)を、シミュレータで使

用可能な形式(txyz 形式)のファイルに変換します 

 

１． “Open Babel GUI”を起動 
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２． mol 形式から txyz 形式ファイルへの変換 

１）”INPUT FORMAT”から、”mol – MDL MOL format”を選択します 

 

 

 

 

 

 

 

 

 

 

 

 

 

２）”OUTPUT FORMAT”から、”txyz – Tinker MM2 format”を選択します。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

３）①”Input below”チェックボックスのチェックをはずし、②ChemSketch で作成した

mol ファイルを指定します。(注)指定する mol ファイルのパスには、日本語文字を含め
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ないようにしてください。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

４）①”Input below”チェックボックスにチェックを入れます。②”Output below only”チ

ェックボックスのチェックをはずし、③出力する場所を指定し、ファイル名を入力しま

す。(注)指定する mol ファイルのパス、及びファイル名には、日本語文字を含めないよ

うにしてください。 

 

 

 

 

 

 

 

 

 

 

 

 

② 

① 

① ③ 

② 
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５）”CONVERT”ボタンをクリックします。 

 

 

 

 

 

 

 

 

 

 

 

 

 

６）４)－③で指定した場所に、mol ファイルを変換した txyz ファイルが生成されます。 
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第５章 

実測画像－シミュレーション画像比較機能 
 

 

 

1 概要 １ 概要                     

 
 

実測画像－シミュレーション画像比較機能 GUI（以下 Analyzer）では、SPM の測定画像や

各種解析ソフトの出力データ、本シミュレータの計算結果、論文からのキャプチャ画像な

ど、様々な形式のデータを読み込み、２次元、３次元画像として可視化することができま

す。これらの画像を並列表示することで、各画像を容易に比較することができます。また

読み込んだデータを様々な形式で保存できるため、データ形式変換ソフトとしてもご使用

いただけます。また測定の際に生じる傾斜を自動補正する機能や画像からの探針推定機能、

測定画像から探針の影響を取り除く機能なども備えています。さらに、画像のフーリエ解

析や高解像度化機能、ニューラルネットを用いた探針影響除去機能なども備えています。 
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2 画面説明 

 

シミュレーション画像 

シミュレータ Analyzer

MD 

FEM 

DFTB 

CG 

LIQ 

GEO 

解析ソフト 

実測画像 

SPM装置 

解析画像 

論文等 

キャプチャ画像 

並列表示 

２ 画面説明 
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Menu Bar & Tool Bar 

 

以下では画面ごとの主な機能について説明します。 

 

【Analyzer】 

Image View 

Cross Section View 

Data View 

Image View 

Image View 

Analyzer 
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ウィンドウ画面全体を表します。 

 

【Menu Bar & Tool Bar】 

データファイル読み込みや保存などのファイル操作、Image View の整列やクローズな

どのウィンドウ操作を行います。 

 

【Image View】 

読み込まれたデータファイルの内容を２次元および３次元画像として可視化します。

マウスやキーボードの操作によって、視点の変更や拡大縮小を自由に行うことができ

ます。またマウス操作によって、対象を任意の位置で切断することができ、その断面

図は Cross Section View で見ることができます。なお、このウィンドウは同時に複数

表示することが可能であり、並列表示などが行えます。 

 

【Cross Section View】 

Image View で切り取られた断面をグラフ表示します。 

 

【Data View】 

読み込んだデータファイルの内容を表形式でテキスト表示します。 

 

 

３ Analyzer の起動と終了 
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3  Analyzer の起動と終了 

 

 

【起動】 

 

 

1. シミュレータ本体 GUI “Menu Bar” → [Tool] → [Analyzer] 

 

以上の操作によって、実測画像－シミュレーション画像比較機能用の GUI である Analyzer

が起動します。 

 

【終了】 
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1.Analyzer“Manu Bar”→ [File] → [Exit]  

 

以上の操作で Analyzer は終了しますが、シミュレータ本体の GUI は終了しません。 

 

 

4 ファイル操作 ４ ファイル操作 

  

 

Analyzer では、様々なメーカーの SPM 測定画像の他、本シミュレータの計算結果や論文

からのキャプチャ画像などのデータファイルを読み込むことができます。また読み込んだ

データは別の形式に変換して保存できます。さらに Image View の描画を、そのまま画像と

して保存するキャプチャ機能も備えています。ここでは、データファイルの読み込みと保

存、描画のキャプチャ方法について説明します。 

 

█ データファイルの読み込み                       

【ファイルダイアログを使用した読み込み】 
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Image View 

 

1. “Menu Bar” → [File] → [Open]42 → ”Open File”ダイアログ 

2. データファイル指定 → [開く] 

 

Analyzerでは、一般の画像形式（jpeg,bmp,png,tif）、Cube（本シミュレータ出力形式）、各

                                                  
42 この操作は、”Tool Bar” → Openアイコンをクリックすることでも行えます。 
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種装置メーカー・解析ソフト出力形式（Unisoku、Omicron、Gwyddion、WSxM、SPIP、

Asylum、Surf）に対応しています。指定されたデータファイルが読み込まれると、Image View

が表示され、その中に２次元画像43が描画されます。 

 

【最近使用したデータファイルの読み込み】 

 

1. “Menu Bar” → [File] → [Recent Files] → データファイル一覧44→データファイル指定 

 

【一般の画像形式のデータファイルの読み込み】 

bmp や jpg などの画像ファイルは、明るさの情報はもちますが、例えば高さ情報はもって

いません。したがって、データを読み込む際には、明度を実際の高さ情報に変換する処理

が必要となります。また、画像の大きさ（縦横サイズ）が現実に何Åかということを指定す

る必要があります。以下では画像ファイルの読み込みについて説明します。 

                                                  
43 ３次元表示など、描画法の変更については後述します。 
44 最近使ったプロジェクトファイルは最大 10 個まで表示されます。 
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1. “Menu Bar” → [File] → [Open]45 → ”Open File”ダイアログ 

2. データファイル指定 → [開く] 

3.”Set scale”ダイアログ → “Distance between pixels”入力 → [OK] 

4.”Set Value Range”ダイアログ → “value range”入力 → [OK] 

 

“Set scale”ダイアログで、画像ファイルのピクセル間の距離が実際には何Åに対応するのか

を指定します。さらに“Set Value Range”ダイアログで、画像の明度[0.0,1.0](黒=0.0、白=1.0

で表現)がどれくらいの高低差（Å）に相当するのかを指定します。 

 

                                                  
45 この操作は、”Tool Bar” → Openアイコンをクリックすることでも行えます。 

 175



█ データファイルの保存                          

 

読み込んだ様々な形式のデータファイルを別名および別形式で保存することができます。 

 

 

1. a. “Manu Bar”→ [File]  

  b. “Image View”右クリック46 → コンテクストメニュー 

2. [Save As]47 → “Save As ”ダイアログ → ファイル名指定 → [保存] 

イメージの保存                          

 

 

█ 

 

数値データそのものだけではなく、Image View に表示されている画面自体を画像として保

                                                  
46 複数のImage Viewが立ち上がっている場合は、保存したいデータが表示されているImage View上で右クリックしてく
ださい。 
47 この操作は、”Tool Bar” → Saveアイコンをクリックすることでも行えます。 
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存することができます。 

 

1. a. “Manu Bar”→ [File]  

  b. “Image View”右クリック → コンテクストメニュー 

2. [Export Image]48 → “Export Image ”ダイアログ → ファイル名指定 → [保存] 

画像のフーリエ解析・高解像度化 

FFT 解析を用いた画像処理、Lanczos 補間を用いた画像の高解像

 

                                                 

 

 

５ ５ 画像のフーリエ解析・高解像度化 

 

 

本機能を用いることで、

度化処理を行うことができます。

 

 
48 この操作は、”Tool Bar” → Export Imageアイコンをクリックすることでも行えます。 
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█ 画像のフーリエ解析                      

 

【データ描画】 

 
 

Image Processing View 

Mode Combo Box 

Cartesian Fourier Power Spectrum 

 

1. “Image View”右クリック → コンテクストメニュー → [Image Processing] →”Image 

Processing View” 

2. “Tool Bar” → “Mode Combo Box” → [Cartesian/Fourier/Power Spectrum] 
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）49、Power 

pectrum（パワースペクトルグラフ）50の表示を切り替えることができます。 

                                                 

“Mode Combo Box”において、Cartesian（通常画像）、Fourier（フーリエ画像

S

 

【画像処理】 

 
49 Fourier画像の値はLog Scaleで表示しています。 
50
 Power Spectrumは両対数グラフとして表示しています。 
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Slider Bar

 

1. “Tool Bar” → “Slider Bar” 移動 

2. “Tool Bar” → [Reset] クリック 

Cartesian Fourier Power Spectrum 

Reset 

高周波強調 

低周波強調 
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“Slider Bar”のつまみを移動させることで、パワースペクトルグラフの傾きを連続的に変化

させることができます51。それに伴って、Cartesian（通常画像）、Fourier（フーリエ画像）

も変化します。つまみを左（右）に移動させると低周波（高周波）を強調した画像になり

ます。また[Reset ]ボタンをクリックすることで、スライダーバーのつまみの位置を、ゼロ

位置に戻すことができます。 

 

【階調補正】 

 

 

1. ”Image Processing View”右クリック → コンテクストメニュー → [Tone Correction]  

 

[Tone Correction]はトグルボタンであり、この操作によって階調補正のオンオフを切り替え

ることができます。 

                                                  
51 グラフを、べき分布、つまり両対数グラフで直線として近似し、その傾きを連続的に変化させていきます。 
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【Analyzer へのエクスポート】 

 

1. ”Image Processing View”右クリック → コンテクストメニュー → [Export to Analyzer]  

”Image Processing View”上の画像を、Analyzer 上の”Image View”にエ

クスポートすることができます。その際、データは、”ファイル名[1].cube”という Cube 形

式のファイルに自動保存されます。 

 画像高解像度化                   

 

この操作によって、

 

█
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1.  “Tool Bar” → [Up Resolution / Down Resolution]  

 

[Up Resolution / Down Resolution]ボタンを押すことによって、画像の解像度を上げたり下

げたり52することができます。画像サイズは”Tool Bar”右端のテキストボックスに表示され

ます。 

 

                                                  
52
 解像度を変える際、Lanczosフィルターを用いた補間処理を行っています。 
 

Up Resolution /Down Resolution Button 

画像サイズ 

画像サイズ 

高解像度画像
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６ ニューラルネットシミュレータ ６ ニューラルネットシミュレータ 

 

 

ニューラルネットシミュレータは、「原画像と観測画像」、「低解像度画像と高解像度画像」

といった何らかの関係のある２種類の画像間の関係を学習することができます。例えば形

状が既知の標準試料をトレーナー画像（正解画像）とし、その SPM 画像を入力画像として

両者の関係を学習させるとします。この場合ネットワークは、探針が SPM 画像に及ぼす影

響を学習していると考えられます。学習終了後、このネットワークに、同じ探針で走査し

たある試料の SPM 画像を入力すると、探針の影響を取り除いた画像が出力されると期待で

きます。 
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Neuralnet Simulator

画像１ 画像２

画像１と画像２の関係を学習

観測過程 探針 SPM画像 試料

学習過程 既知試料 既知試料SPM画像 ニューラルネット

推定過程 推定試料 任意のSPM画像 ニューラルネット

 
 

 

 

█ ニューラルネットシミュレータの起動                      
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1. Analyser“Menu Bar” → [Tool] → [Neuralnet Simulator] 

 

█ 学習データの設定                      
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Select observed images ダイアログ 

 
 

入力画像 

トレーナー画像

Select original images ダイアログ 

Training Data Set ウィンドウ 
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1. Neuralnet Simulator “Menu Bar” → [File] → [Open]53 → ”Select observed images ”ダイ

アログ → 入力画像指定 → [開く] 

2. ”Select original images ”ダイアログ → トレーナー画像指定 → [開く] 

 

以上の操作でニューラルネットシミュレータに学習データ設定されます。学習データは入

力画像、トレーナー画像ともに複数枚指定することができますが、両者は同じ枚数でなけ

ればなりません。設定された画像は、シミュレータの右側（右上：入力画像、右下：トレ

ーナー画像）に表示されます。ただし複数枚指定した場合は、それらの内１セット分だけ

表示されます。 

 

 

█ 学習の実行・停止・一時停止                      

 

【実行】 

 

 
Start 

 
 
 
 
 
 
 
 
 
                                                  
53 この操作は、”Tool Bar” → Openアイコンをクリックすることでも行えます。 

Log View 

 188



 
 
 
 

1.  “Tool Bar” → [Start] 

 

 [Start]ボタンを押すと、学習が開始されます。ニューラルネットからのメッセージは、Log 

View 上に表示されます。 

 

【停止・一時停止】 

Pause Stop 

Error View

 

1. “Tool Bar” → [Stop/ Pause] 

2. “Menu Bar” → [Display] → [Error View] 

 

学習開始後、[Start]ボタンが使用不可となり、[Stop]ボタンと[Pause]ボタンが使用可能とな

ります。[Stop]ボタンを押せば実行を停止し、ネットワークの状態は初期化されます。[Pause]
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ボタンを押すことで、学習を一時停止できます。再開するには、再び[Start]ボタンを押しま

す。学習を一時停止し、Error View を立ち上げることで、各時点でのネットワークの出力画

像とトレーナー画像（正解画像）との平均二乗誤差（Mean Square Error:MSE）の時間発展

を見ることができます。なお、各時点での MSE は、”Log View”上にも表示されます。 

 

█ 学習結果の保存と読み込み                             

 

【保存】 

一時停止、あるいは学習が完了し、ニューラルネットが停止状態にある時には、その時点

での学習状態（ユニット間の重み）を保存することができます54。以下では保存方法につい

て説明します。 

Save Weight File ダイアログ 

 
 

1. “Menu Bar” → [File] → [Save Weight File] → ”Save Weight File”ダイアログ 

2. 保存ファイル名指定 → [保存] 

                                                  
54 [Stop]ボタンを押すと、ネットワークの状態が初期化されてしまいます。保存は[Stop]ボタンを押す前に行ってくだ
さい。 
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【読み込み】 

保存された学習結果ファイルは、ニューラルネットワークに読み込むことができます。こ

れによって、ファイルが保存された時点の学習状態を再現することができます。 

 

Load Weight File ダイアログ 

 
 

1. “Menu Bar” → [File] → [Load Weight File] → ”Load Weight File”ダイアログ 

2. 読み込みファイル名指定 → [開く] 

 

█ 学習結果のチェックと新規入力画像に対する試行           

 

【学習結果のチェック】 
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Input Image Reconstructed Image Difference Image 

 

1. “Tool Bar” → [Check] → ”Input Image/Reconstructed Image/Difference Image” 

 

一時停止、あるいは学習が完了し、ニューラルネットが停止状態にある時には、その時点

での学習状態を視覚的にチェックすることができます。ツールバーの[Check]ボタンを押す

と、その時点のネットワークに学習データセット時に指定した入力画像(Input Image)が入力

され、出力結果画像(Reconstructed Image)が表示されます。またこの結果画像と、はじめ

に学習データとしてセットされたトレーナー画像との差分画像(Difference Image)も表示さ

れます。 

 

【新規入力画像に対する試行】 
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Open File ダイアログ

Input Image Reconstructed Image 

 
 

1. “Tool Bar” → [Trial] → “Open File”ダイアログ 

2. 画像ファイル指定 →  [開く] → ”Input Image/Reconstructed Image/Difference Image” 

 

学習終了後、学習データセット時に用いられた入力画像とは別の画像を使って、そのニュ

ーラルネットワークをテストすることができます。ツールバーの[Trial]ボタンをクリック

し、”Open File”ダイアログで入力画像を指定すると、その時点のネットワークに指定画像

(Input Image)が入力され、計算結果画像(Reconstructed Image)が表示されます。 
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█ ウィンドウの表示／非表示・LogView のクリア           

 

Input Image

 

【ウィンドウの表示／非表示】 

1. “Menu Bar” → [Display] → [Training Data Set / Input Image / Reconstructed Image / 

Difference Image / Error View] 

 

[Display]メニューから表示／非表示したい Window をクリックします。 [Training Data Set 

/ Input Image / Reconstructed Image / Difference Image / Error View]は各々トグルボタンで

あり、クリックを繰り返すことによって、対応するウィンドウの表示／非表示を切り替え

られます。 
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【Log View のクリア】 

Clear 

Log View 

 

1. “Tool Bar” → [Clear]  

 

ツールバーの[Clear]ボタンを押すことで、”Log View”に表示されている文字列が全て消去さ

れます。 
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７ 探針形状推定・探針影響除去 ７ 探針形状推定・探針影響除去 

 

 

本機能を用いることで、測定データのみから、探針形状を自動推定することができます。

また、測定データからその推定探針の影響を取り除いた画像を作成することができます。 

 

█ 探針形状推定                      
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Image View 

 

3. “Image View”右クリック → コンテクストメニュー → [Tip Estimation] 

4. ”Tip Nx”ダイアログ → 数値入力 → [OK] 

3.  ”Tip Ny”ダイアログ → 数値入力 → [OK] 

4.  ”Parameter”ダイアログ → 数値入力 → [OK] 

 

はじめに Image View に測定データを読み込み、コンテクストメニューから[Tip Estimation]

を選択します。次に Tip Nx と Tip Ny ダイアログで、各々推定する探針の横と縦のサイズ（ピ
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クセル単位）を指定します。最後に Parameter（[0.0,1.0]区間の実数）を指定します。この

指定によって、無数にある探針の解候補のうち、最大探針（Parameter=0.0）から、最小探

針（Parameter=1.0）まで推定することができます。推定された探針は、データファイルと

同じフォルダに tip_result.cube というファイル名で自動保存されると同時に、新たな Image 

View が立ち上がり、その形状が描画されます。 

█ 探針影響除去                     
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1. “Image View”右クリック → コンテクストメニュー → [Eliminate Tip Effect] 
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2. ”Select Tip”ダイアログ → ファイル名指定 → [OK] 

 

測定データが表示されている Image View 上のコンテクストメニューから[Eliminate Tip 

Effect]を選択します。次に探針を指定し、測定データから探針の影響を取り除いた画像デー

タ を 出 力 し ま す 。 探 針 影 響 除 去 画 像 は 、 デ ー タ フ ァ イ ル と 同 じ フ ォ ル ダ に

image_eliminated_tip_effect.cube というファイル名で保存されると同時に、新たな Image 

View が立ち上がり、形状が描画されます。 

 

 

８ 可視化設定 ８ 可視化設定 
 

 

█ 描画法の変更                     

 

【2D／3D 表示切り替え】 

 

以下では２次元表示から３次元表示への切り替えについて説明します。 
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1.“Image View”右クリック → コンテクストメニュー → [3D-View] 

 

 

【断面図の表示】 
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1.“Image View”上ダブルクリック → 始点決定 

2.“Image View”上ダブルクリック → 終点決定 

3.“Image View”右クリック → コンテクストメニュー → [3D-View] 
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4.“Image View”右クリック → コンテクストメニュー → [Cross-Section] → [Clipping] 

 

 

 

始点と終点の指定は、２D 表示にして行います。終点の指定が終了すると、自動的に Cross 

Section View が立ち上がり、断面図がグラフ表示されます。３D 表示に切り替えてコンテク

ストメニューから[Clipping]を選択することで、３D 画像を切り取ることができます。元に

戻すには、再度[Clipping]を選択します。また[Clear]を選択すると、始点終点位置などの切

断情報がクリアされます。 

 

【Z 軸の反転】 

 

 
 

1.“Image View”右クリック → コンテクストメニュー → [z-range Reverse] 55

 

【Z 軸の正規化】 

                                                  
55  [z-range Reverse]はトグルボタンであり、繰り返しクリックすることでZ軸反転の有無を交互に切り替えられます。 
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1.“Image View”右クリック → コンテクストメニュー → [z-range Normalize] 56

 

縦横サイズに比して高低差が非常に小さい場合、３D 表示しても見た目は平面とほとんど変

わりません。そのような場合、Z 軸を正規化することで、高低差を強調して表示することが

できます。 

 

【描画色の設定】 

                                                  
56  [z-range Normalize]はトグルボタンであり、繰り返しクリックすることで正規化の有無を交互に切り替えられます。 
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Gradation Monocrome Rainbow 

 

1. “Image View”右クリック → コンテクストメニュー 

2. [Color] → [Monocrome / Gradation / Rainbow] 

 

以上の操作で、描画色の設定を変更することができます。 

 

【ライティング】 
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1.“Image View”右クリック → コンテクストメニュー → [Lighting] 57

D 表示の場合のみ有効です。 

 

                                                 

 

この処理は、３

 

【等高線表示／非表示切り替え】

 
 

 
57  [Lighting]はトグルボタンであり、繰り返しクリックすることでライティングの有無を交互に切り替えられます。 
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1.”Image View”右クリック → コンテクストメニュー → [Isoline]58

 

【表示タイプの切り替え】 

 
 
                                                  
58  [Isoline]はトグルボタンであり、繰り返しクリックすることで等高線の表示／非表示を交互に切り替えられます。 
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Fill Wire Frame

 

1. “Image View”右クリック → コンテクストメニュー 

2. [Display-Type] → [Fill / Wire Frame] 

 

この処理は、３D 表示の場合のみ有効です。 

 

 

█ 視点の変更・Zoom All・拡大縮小・遠近法表示                   

 

以下の処理は、３D 表示の場合のみ有効です。 
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【視点の変更】 

Top Front Side 

 
 

1.”Image View”右クリック → コンテクストメニュー 

2. [Top/Front/Side] 

 

この操作を行うことで、真上（Top）、正面（Front）、真横（Side）に視点が変更されます。

また、Image View 上をドラッグすることにより視角を自由に変更することもできます。

[Shift]+ドラッグすることにより、視点を平行移動させることができます。 
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【Zoom All】 

 

1.”Image View”右クリック → コンテクストメニュー → [Zoom All] 

 

この操作によって、描画が”Image View”画面全体に収まるように、自動的に拡大縮小および

平行移動が行われます。 

 

【拡大縮小】 

1. マウスホイール→回転 

マウスホイールを回転させることで、任意の倍率にスケーリングすることができます。 

 

【遠近法表示】 
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1. ”Image View”右クリック → コンテクストメニュー → [Perspective]59 

 

 

９ その他 ９ その他 

 

 

█ データ表示                      

 

                                                  
59 [Perspective]はトグルボタンであり、この操作によって遠近法表示のオンオフを切り替えることができます。 
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1.“Image View”右クリック → コンテクストメニュー → [Show Data]  

 

Data View を用いて、数値データを表形式で閲覧することができます。 

 

█ 傾き自動補正                            

 
 

1.“Image View”右クリック → コンテクストメニュー → [Correct tilt]  
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█ Image View の整列・クローズ                      

 

【タイル表示】 

 

 

1. “Menu Bar” → [Window] → [Tile] 

 

【カスケード表示】 
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1. “Menu Bar” → [Window] → [Cascade] 

 

【Imege View のクローズ】 

 

 

1. “Menu Bar” → [Window] → [Close All] 

 

この操作によって、全ての Image View が閉じられます。 
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